1

I noticed that the clock of my Windows 10 Desktop has been set back one hour every day I boot the system for the first time. The three possible auto-settings afaik for changing the time automatically (automatic setting of time, timezone and summer/winter offset) are off. The timezone has been set correctly during installation and I never touched it. I adjusted the time every morning for the past couple of days.

For some time I had all auto-settings on (or just the adjust time and summer/winter automatically with the timezone CET/Berlin set manually without auto-update) which didn't change the time to the correct value over days and multiple reboots.

I'm running Windows 10 in a DualBoot with Ubuntu 18.10 which has the same settings regarding time (auto-update), timezone (CET/Berlin without auto-update) and summer/winter offset (auto-update) and it works fine there.

1

This phenomenon is caused by management of time on Windows and Ubuntu based on different base timezones. The solution is to make them both manage on the same base.

Set Windows's base to UTC

Recommended because Ubuntu displays a warning if it doesn't track UTC

In case you changed it run on Ubuntu

timedatectl set-local-rtc 0

Then on Windows start cmd as admin and run

Reg add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1

and disable the automatic time adjustement on start.

Set Ubuntu's base to local time

timedatectl set-local-rtc 1 --adjust-system-clock

(from http://ubuntuhandbook.org/index.php/2016/05/time-differences-ubuntu-1604-windows-10/)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.