1

When I use the command

apt --fix-broken install 

I get the following errors:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
libhogweed4 : Depends: libnettle6 (= 3.3-1+b1) but 3.4-1 is installed
mana-toolkit : Depends: dnsmasq but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I am unable to install anything because of this.
What can I do?

1

This is not a simple problem, and I faced a similar one just a minute ago. I solved it by running (a variation on):

  • dpkg --force-all --configure -a
  • dpkg --purge --force-depends libnettle6 (cf. this post)
  • apt --fix-broken install
  • apt-get -f install
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.