11

I attempt to share a WiFi-Internet connection with an Ethernet port. The Wifi is secured with an enterprise 802.1X authentication (so there is no preshared password like in home Wifi's).

Whenever I bridge the WiFi adapter with the Ethernet adapter, the Internet connectivity breaks (right click -> bridge in Windows 10 system control panel).

As soon as I remove the bridge, the WiFi adapter restores the Internet connectivity. Configuring any static IP addresses does not work.

It appears to me that the bridge destroys the wireless configuration. How can I configure a Windows 10 bridge that leaves the wireless configuration unchanged? (note that I do not care about the Ethernet configuration as long as I have a working Internet gateway)

12

Wi-Fi cannot be bridged to Ethernet. This is not a Windows limitation in any way. There’s a good explanation on why that is in the old OpenWrt wiki.

Instead, you should use Internet Connection Sharing (ie. make your PC a router):

  • Go to the Network Connections control panel (where you’re currently trying to create the bridge)
  • Open your Wi-Fi connection’s properties.
  • Switch to the “Sharing” tab
  • Enable it, selecting your Ethernet connection as the “Home networking connection”.

Everything should automatically work after that.

3
  • 4
    But sir, it created NAT connection, what if there is a requirement of bridge connection? i.e. the IP of VM should be similar to the external(LAN) network. – Mayur Jun 21 '19 at 9:20
  • 1
    "Wi-Fi cannot be bridged to Ethernet" -- This statement is not true. Your link is talking about it not being supported by OpenWrt. That doesn't mean it's not possible at all. – Kelly Bang Jan 6 at 0:25
  • @KellyBang You didn't read the link properly. It's helpful to read the text and look at the diagram. "The 802.11 standard only uses three MAC addresses for frames transmitted between the Access Point and the Station. Frames transmitted from the Station to the AP don't include the ethernet source MAC of the requesting host and response frames are missing the destination "ethernet MAC to address the target host behind the client bridge." – Matt H Feb 15 at 18:19
2

Wi-Fi CAN be bridged to Ethernet on Windows 10.

  1. Connect to Internet via WiFi.
  2. Take note of your private IP settings
    (e.g. IP:192.168.1.44 SM:255.255.255.0 GW:192.168.1.1 DNS:192.168.1.1)
  3. In Control Panel > Network and Internet > Network Connections, highlight WiFi and Ethernet (use shift click or Ctrl Click or shift arrow key). Rt-click on highlighted area and choose "Bridge Connections"
  4. At this point, hosting PC will likely lose Internet especially if you connect a device on the Ethernet port.
  5. To correct this loss of Internet on "host PC", go to Control Panel > Network and Internet > Network Connections, and double-click "Network Bridge" to open Network Bridge Status dialogue.
  6. Click Properties button (might be slow to populate, be patient)
  7. Highlight WiFi in top box
  8. Double-click IPv4 in bottom box to open IPv4 Properties
  9. Select "Use the following IP address" and manually fill in settings recorded from step TWO.
  10. OK your way out
  11. Enjoy Internet on both your "host PC" as well as add-on device connected to host PC via Ethernet (extension of your WiFi network).

Note1: This also works with LAN-LAN bridge

Note2: I disabled IPv6 on "wireless bridge" but probably unnecessary.

0

Not only can you do it. I was able to keep the internet flowing into my host computer.

First create your bridge. then remove and add your components to the bridge until you have internet flowing into your clients.

then use another adapter to open the flow of internet back into your host.

Easy peasey, nice and easy.

-1

It can be done, but it's not always easy/straight forward. Whenever my bridge breaks, it usually takes me a few hours to get it working again.

In my case, I have a TL-WDN4800 (my Wi-Fi card) bridged with the Intel Ethernet port on my GA-Z170X-Gaming7. Some guides will tell you it matters what order you add everything to the bridge in.

Most recent experience:

  1. Create the bridge starting with the WiFi adapter. Next add the Ethernet adapter. (You can try doing both at the same time).
  2. Machine likely needs a reboot in order to recognize the bridge properly. Mine did last time. Do it for good measure.
  3. Connect to your Wi-Fi, if it doesn't automatically connect. I usually have to manually reconnect.
  4. Profit.

In my case, I'm bridging to my Unraid server, where I've set what IP it should use on the local network. If you check the Network Bridge in your Network Connections, my speed usually shows the combined speed of the bridged connections.

Ex. my Wi-Fi is a 450 Mbps connection, Ethernet is a 1 Gbps, Network Bridge shows 1.4 Gbps.

-1

Well it still works. I am using bridge connection with my 1 Gbps Ethernet and 65 Mbps Wi-Fi and by somehow it managed to get 1.5 Gbps (I don't know if it is a bug or true, but I am sure that is what it tells me)

1
  • Steps to explain how you do it, would be useful. Otherwise, this seems more like a comment than an answer. – Greenonline Aug 20 '20 at 2:53
-2

Someone seems a bit techy about my phrasing?

The complete answer to the question isn't simplistically that it's impossible, but rather

a) While Linux does this seamlessly with Hostapd, Windows cannot yet* because it does not have support for wifi AP mode, only Station mode (-Thanks Daniel)

b) Windows does provide a partial workaround:

The first step is to use ICS and set up a mobile hotspot (as described by Daniel). This gives internet access to hotspot clients, however the clients are not visible over the lan because they are on a separate subnet (and Windows does not yet bridge this).

The second, cumbersome, part to access hotspot clients from the lan, would be setting up ssh or equivalent tunnel(s) from lan clients to the Windows Hotspot PC and then on to the clients.

C) While you could do this if you were tied to Windows, all told it would be easier at the moment to use Linux or a hardware solution by buying a $50 Wifi AP.

*However I've heard of, but not yet tried Connectify which may now let Windows do this seamlessly too. Can anyone confirm?

-3

I've been bridging a WiFi to Ethernet for along time now so it can be done and it is easy and straightforward. Just highlight both connections right click and select bridge connections and you're done. I don't think you can add them one at a time as suggested above, you need two connections to create a bridge, it won't work one at a time.

However, the problem you are experiencing is that the Bridge is not picking up an IP address from your router and because it has no address it's no longer part of the network and cannot communicate so breaks the internet connection. I'm assuming that the WiFi is the path to the router and the Ethernet connection is to a NAS or something next to your computer?

This also happens to me periodically and I haven't figured out why it does it. Basically, the bridge will assume the name of your WiFi connection when it has an IP address and will change to unknown network when it hasn't got an address. I can go for weeks and it works fine and then it will just drop the network connection and won't reconnect until I reboot the computer and can take ages once I've done that. My thoughts are that the IP address gets renewed by DHCP periodically (IP Lease time) and for some reason on this occasion it won't pick up a new address when it's time to renew it. I think many modem/routers have a very short lease time like 1 hour by default. Perhaps try increasing the lease time to several days and then it might not happen as often.

In fact I just checked mine and it was indeed set to 1 hour. The maximum I could set it to was 21 days or 504 hours which I have done.

I'm winging this as I go along and I thought why not assign a static address to eliminate any DHCP issue and negate lease times. So I created a static lease in the router and manually applied it to the bridge so we'll see how that goes.

Hope this is of help.

Not the answer you're looking for? Browse other questions tagged or ask your own question.