1

I am using WMI to authenticate to a remote windows machine and not able to succeed. Therefore to dig deeper, I have used wbemtest and then tried to connect to the windows machine and got the below error message "RPC Server is unavailable".

Any pointers on how to further narrow this would be very helpful.

Frequent Error:

Number: 0x800706ba
Facility: Win32
Description: The RPC server is unavailable.

Occasional Error:

Number: 0x80070776
Facility: Win32
Description: The object exporter specified was not found.

Tried Steps:

  • In wbemtest, I have tried using both hostname and IP address and it doesn't succeed and got the same above error.
  • I have tried testing the connectivity and I am able to do telnet on port 135 (RPC) and port 445 (WMI) successfully. So this doesn't looks like a connectivity issue. In addition firewall on the target machine is turned off.
  • Verified the following services are running on the target server.

    • DCOM Server Process Launcher
    • Remote Procedure Call (RPC)
    • RPC Endpoint Mapper.
    • TCP/IP NETBIOS Helper
    • Windows Management Instrumentation
  • Network connection is enabled with "File and Printer Sharing for Microsoft Networks and Internet Protocol Version 6 (TCP/IPv6)"

Additional Information:

  • The target machine is (Windows Server 2016 - Part of Workgroup) and the source machine is (Windows 10 - Connected to a Domain)
  • Created a local user account in source machine and tried to connect to target machine but then also it has given the same error message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.