0

I'm running an emulation game in my Lenovo laptop on a Windows platform, but the CPU starts to throttle after a few minutes, which clearly shows a massive clock speed decrease from 3.38GHz (maximum clock speed) to 1.58GHz, which is even smaller than the base clock speed (1.8GHz). Not only the CPU, but also the Nvidia MX150 GPU starts to throttle at the same time.

When I checked the temperature of the CPU right before the thermal throttling was applied with XTU, it was only around 70 degrees. Not that cool, but also not that hot to damage a piece of hardware. After the throttle, the system continues to cool(?) the CPU back to a temperature below 60 degrees, and then returns the clock speed back to the maximum, and throttles again. This repeats all the time!

I want to say that Lenovo is stupid to set a temperature rate of throttling that makes it so easy to throttle, but are there any ways to force the CPU to run at its maximum clock speed all the time? I saw the fan running at its maximum speed, and it is possible for the fan to maintain the CPU's temperature, but Lenovo's stupid thermal plan just blocks all the capabilities that the CPU can make. Even in the BIOS settings, there is no detail of controlling the throttling.

  • It may be more satisfying for you to get consistent 90% performance, based on limiting the frame rate in the emulator or limiting the CPU usage of the one application using Process Lasso or Process Tamer. I say this, having damaged a CPU from overheating in the past. – Christopher Hostage Dec 21 '18 at 20:15
  • What is the second suggestion mean? – Felix Lee Dec 21 '18 at 20:20
  • 1
    CPU cores don't run constantly. The OS splits work into very short slices, and tells individual cores to turn on for individual slices. On a laptop, the cores are usually idling, allowing the laptop to be cool and use less battery. Programs like I mentioned can limit the actual amount of time per second that your emulator uses, so the chip is cooler overall. Try limiting the emulator, see if it's good enough performance, and see if it doesn't overheat. superuser.com/questions/214566/… – Christopher Hostage Dec 21 '18 at 20:32
  • Okay.. It's really weird that the emulator only uses 30~40% of CPU (all the other programs are closed) and 50% of my Nvidia GPU. However, throttling still occurs. My emulator is set at limiting the speed by 100%, and it still shows the same framerate even though I increased the limit. – Felix Lee Dec 22 '18 at 1:40
1

You could try the tool ThrottleStop, which does exactly what the name suggests.

ThrottleStop 8.70 screenshot

Word of caution: 70 degrees Celcius is not too hot, but it is hot enough to potentially damare your laptop. You might consider a desktop computer, which is generally better equiped for prolonged high loads.

Finally a recommendation from the ThrottleStop website:

When using ThrottleStop, it is strongly recommended to monitor power consumption at the wall with a Kill-a-Watt meter or similar device and make sure that you don't exceed the power capabilities of your power adapter. Use of ThrottleStop to bypass these throttling schemes is at your own risk and can result in permanent damage to your power adapter or computer or both which may not be covered by your warranty.

  • I tried throttle stop, which I undervolted by -100mV and set the speed shift EPP to 156. The game performance with the program showed around 2.4GHz without a noticeable clock speed drop, which was okay, but running the game with 2.4GHz was slower than 3.38GHz and definitely not satisfied.. – Felix Lee Dec 21 '18 at 20:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.