2

I have connected my MacBook Pro to two Wi-Fi networks via two separate adapters. One is my Internet network and the other is a local network with some devices.

My MacBook Pro Wi-Fi card is connected to the Wi-Fi network for Internet. I have a Edimax EW-7822ULC Wi-Fi USB 2.0 Adapter and this is connected to the other network via the Edimax config settings.

Now, my MacBook Pro is not able to connect to the Internet because it tries to access the Internet via the other network. Why is it not connecting to the Internet via the network that the in built Wi-Fi card is connected to?

How do I fix this? Shouldn’t it automatically choose the correct network?

  • 1
    How do I stay connected to both the networks? There are some devices on the other network that I want to access. But I want the internet connection to continue working. How is this different from having two Ethernet adapters/cards on a PC? The question is why is the computer not able to connect to the internet anymore? – A j Dec 22 '18 at 11:18
  • Oh! I am sorry. I somehow thought you were attempting to connect to two networks with one adapter. I somehow missed that you have a Edimax EW-7822ULC Wi-Fi USB 2.0 Adapter. To use the Edimax USB adapter in this way you need to install their driver software for that device. Once installed, reboot and there will be a menu item for the adapter. Set that adapter to use one network and then set the built in Wi-Fi to use the other network. This should work. Simply plugging in the USB Wi-Fi adapter won’t do anything for you without installing the drivers. – Giacomo1968 Dec 22 '18 at 15:23
  • I have installed the device driver and have connected to both the networks. The problem is that even though I am connected to the Internet network I am not able to access any websites. – A j Dec 22 '18 at 15:50
  • Don't know MAC, but fundamentally you need to change the routing table. Say your company hands out 192.168.0.0/16 ip address then that entry is added so it points to the correct network adapter. The default should be your internet connection. Googling suggests sudo route -n add -net 192.168.0.0/16 <ip address of company network adapter or gateway> – cybernard Dec 22 '18 at 19:12
  • @cybernard: But this seems odd. Why then do so many systems work fine with two interfaces without having to fiddle manually with routing tables? Or are you saying that there are two different subnets in place and that is causing issues? One subnet on built-in Wi-Fi versus USB Wi-Fi and one can’t reach the other due to this setup? – Giacomo1968 Dec 22 '18 at 20:33
0

I was able to fix the problem of accessing Internet by moving the Internet router up the priority list in Preferences->>Networks.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.