0

It just doesn't.

I'm fairly certain this is an issue with my computer, possibly due to the path variables, because I get the same problem with qt 5.11 as well as qt 5.12. It also seems like I'm not the only one who's had this problem—see this question—which works, but it's going to be pretty painful to do this for every *.ui file and dump it exactly where visual studio and/or the build bat script that MuseScore comes with expects it to be.

This is an example of what I'm trying to do and a fairly annoying work around:

Microsoft Windows [Version 10.0.17134.471]
(c) 2018 Microsoft Corporation. All rights reserved.

C:\ProjectFiles\mscore\MuseScore\zerberus>uic zerberus_gui.ui -o ui_zerberus_gui.h

C:\ProjectFiles\mscore\MuseScore\zerberus>ls
CMakeLists.txt  channel.h   instrument.cpp  sfz.cpp    zerberus.cpp     zerberusgui.cpp  zone.h
README          filter.cpp  instrument.h    voice.cpp  zerberus.h       zerberusgui.h
channel.cpp     filter.h    sample.h        voice.h    zerberus_gui.ui  zone.cpp

C:\ProjectFiles\mscore\MuseScore\zerberus>uic zerberus_gui.ui > ui_zerberus_gui.h

C:\ProjectFiles\mscore\MuseScore\zerberus>ls
CMakeLists.txt  channel.h   instrument.cpp  sfz.cpp            voice.h       zerberus_gui.ui  zone.cpp
README          filter.cpp  instrument.h    ui_zerberus_gui.h  zerberus.cpp  zerberusgui.cpp  zone.h
channel.cpp     filter.h    sample.h        voice.cpp          zerberus.h    zerberusgui.h

This is what my path variables look like:

C:\ProjectFiles\mscore\MuseScore\zerberus>echo %PATH%
C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Common Files\Propellerhead Software\ReWire\;C:\Program Files\Common Files\Propellerhead Software\ReWire\;C:\Program Files (x86)\PuTTY\;C:\Program Files (x86)\GtkSharp\2.12\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files\Git\cmd;C:\Program Files\Git\usr\bin;C:\Program Files\CMake\bin;C:\Users\Michael\AppData\Local\Programs\Microsoft VS Code\bin;C:\Qt\Tools\QtCreator\bin;C:\Qt\5.12.0\msvc2017_64\bin;C:\Users\Michael\AppData\Local\Microsoft\WindowsApps;C:\Users\Michael\AppData\Local\Programs\Microsoft VS Code\bin;C:\Users\Michael\AppData\Local\GitHubDesktop\bin;

C:\ProjectFiles\mscore\MuseScore\zerberus>

This is the build output from when I tried to build MuseScore; output too large so posting on PasteBin.

Hopefully I can get this going before MuseScore 3.0 is released to fix a few bugs.

0

Problem solved.

I'm using an antivirus called Comodo which is usually actually quite good, but the "sandbox" feature is a little overzealous and makes things silently fail in odd ways, I usually keep it off but it somehow came on again. UIC is currently working now.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.