0

I have a 2 identical disk storage space that I hadn't used in a while. Yesterday when I plugged them in, it was showing a warning on one disk (no details, just the warning icon). So, I figured I could just remove that disk and re-add it to see if it would sort it self out. However, it just got suspended in removing state. I had also previously tried optimizing the storage space thinking the error would go away. Now I find that the space is stuck on both operations I had left it overnight thinking it would just be trying to move data from the disk being removed to the other. However, the status didn't change after 8+ hrs. I plugged them in to a different machine and the status is the same.

Status of Storage Space

When I try to copy files from the space to another drive, I get this error:

Storage Space Error

Here are some info that were requested in other forums that might be useful to troubleshoot: PS Scripts CrystalDiskInfo

(Disk 2 and 3 are the ones in the Storage Space)

How can I get around this issue?

Update 1:

As suggested by @shawn, ran chkdsk which came up with ended with: Stage 3: Examining security descriptors ... Security descriptor verification completed. 556 data files processed. CHKDSK is verifying Usn Journal... A disk read error occurredc0e7001c Insufficient disk space to fix the Usn Journal $J data stream.

  • have you tried a chkdsk on it yet? chkdsk e: /f /r /x – shawn Dec 23 '18 at 8:29
  • @shawn Thanks! I updated the question with output. As it says A disk read error occurredc0e7001c Insufficient disk space to fix the Usn Journal $J data stream. would adding a new disk to the pool help in this case? (but, it does have plenty more space already). – Scorpion Dec 23 '18 at 13:50
1

Adding another device to the pool definitely won't fix it. Most likely your MFT is corrupted. I've seen this same thing where a corrupted MFT made the drive appear to be 200x its actual size, and chkdsk would fail as a result. You can try dumping the journal first. Run this in an elevated command prompt:

fsutil usn deletejournal /D e:

Then run chkdsk again.

chkdsk e: /f /r /x

If that works, you're fine. If not, I would get the data off, wipe it (DBAN), reformat, finally running chkdsk again and run a SMART check on it to be sure it's not dead or dying. If everything there goes well, you can re-add it to the pool.

  • I think I got further with fsutil than before. However, it still ended with Stage 5: Looking for bad, free clusters ... 374963571 free clusters processed. Free space verification is complete. Adding 166177 bad clusters to the Bad Clusters File. Correcting errors in the Volume Bitmap. An unspecified error occurred (6e74667363686b2e 1546). With most saying The disk does not have enough space to replace bad clusters – Scorpion Dec 24 '18 at 2:20
  • I'd replace any drive with that many bad clusters. 166177 in a single pass is huge. robocopy your stuff to a safe place - robocopy "e:" "q:\backup" /r:5 /w:1 /mir /e /xj /copyall /zb /j (assumes your backup copy is going to be on the Q: drive), then replace the drive. – shawn Dec 24 '18 at 3:03
  • Got it, thanks! Ordered a new drive and will move them as soon as it arrives. Unfortunately, looks like some of the files will not be recoverable :( I guess I knew I'd be in that spot when I didn't set up the space for resilience. – Scorpion Dec 24 '18 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.