0

So i have a Zoiper app on cell phone and I'm trying to make a test call on a new Asterisk server with Digital Ocean. It connects and registers just fine, and seems to at least acknowledge I'm trying to make a call but beyond that just sits there and does nothing. On my end with Zoiper it acts like it's connected but just sits there with no noise or anything. As long as I sit nothing happens. I eventually just end the call.

pjsip.conf

...
[600155]
type=endpoint
transport=transport-udp
context=from-internal
disallow=all
allow=ulaw
auth=600155
aors=600155
direct_media=no
rtp_symmetric=yes
force_rport=yes
rewrite_contact=yes  ; necessary if endpoint does not know/register public ip:port
ice_support=yes   ;This is specific to clients that support NAT traversal
                   ;for media via ICE,STUN,TURN. See the wiki at:
                   ;https://wiki.asterisk.org/wiki/x/D4FHAQ
                   ;for a deeper explanation of this topic.

[600155]
type=auth
auth_type=userpass
password=pear
username=600155

[600155]
type=aor
max_contacts=2

extensions.conf

[from-internal]
exten = 100,1,Answer()
same = n,Wait(1)
same = n,Playback(hello-world)
same = n,Hangup()

The output when I connect my Zoiper app and proceed to dial 100, the last entry occurs when I hit the dial button and nothing more happens from there.

...
 == Endpoint 600155 is now Reachable
    -- Added contact 'sip:600155@####:9880;rinstance=dd647b30dc97700c' to AOR '600155' with expiration of 60 seconds
  == Setting global variable 'SIPDOMAIN' to '####'

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.