1

I just installed MySQL in a Windows 7 32-bit PC.

I tried running the command client but it just flashed over my screen and crashed, so I tried using cmd to run MySQL. I added its location to path in system variables and then I started it with cmd and it worked fine, but when I use commands like "create database" or "show database," nothing happens.

Instead, the cmd somewhat crashes as in, it doesn't do anything after that, it doesn't even close when I type "exit."

This is my first time asking a question here so it might be problematic. Please help me?

closed as unclear what you're asking by DavidPostill Dec 24 '18 at 18:34

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • My guess is you don't put semicolon ; after commands, so MySQL treats is as one long command that happens to contain newlines. – gronostaj Dec 24 '18 at 21:07
  • i added the semi colon after the command and pressed enter, but now it says "you have an error in your sql syntax; check the manual that corresponds to your mysql server version for the right syntax to use near '' at line 1 " – satyam pandey Dec 29 '18 at 16:52
  • can i add a screenshot of the screen here? – satyam pandey Dec 29 '18 at 16:54
  • The message says it all: what you entered is not valid SQL. SQL itself is off-topic on Super User. – gronostaj Dec 29 '18 at 18:38
  • thanks mister. you're awesome i understand it now – satyam pandey Dec 30 '18 at 3:35

Browse other questions tagged or ask your own question.