Somehow I keep getting a Not enough resources to install device error whenever I try to install the Hamachi network adapter, and I tried installing other tunneling services but their network adapters can't seem to install either.

How would I solve this? Is there anywhere I can find more specific errors other than just this?

3 Answers 3


Are there other programs running when you try to install this? Are you using the most recent drivers to install the network adapter?

You can find some more detailed information in the event viewer - eventvwr.exe. Look under the System and Application logs, you should probably find an error there that will be a more detailed description of your problem.

  • I have quite a few programs running, however my CPU usage is at 5% and my ram usage at only 40% (Of 4GB). Also checking the logs I can't see any related errors. May 7, 2010 at 20:18

I would say a likely cause is some type of antivirus or malware protection (up and above simple file scanning, like Comodo's "Defense+" or similar) interfering with the installation of kernel-level drivers such as virtual network adapters. Might also happen if the installer doesn't have the proper privileges.


I reinstalled windows 7 and the problem has disappeared, still weird though.

Edit: I finally found a case were I fixed this, it turns out that for some reason, when I extracted a driver zip file the extracted contents would be read-only + encrypted. Going to the top folder properties and recursively disabling read-only and encrypted fixed it, making it install properly.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .