0

When I reassume my computer from a sleep, I observe sometimes that my wireless adapter is not working. The network connections icon in the system tray on Windows says 'Not connected - No connections available'. My wireless adapter, Qualcomm Atheros QCA9377, has this for the device status:

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

I only observe this problem when I am running VirtualBox running with a VM.

I am running Windows 10 host with VirtualBox guest running Lubuntu 18.04. From VirtualBox, I have two network interfaces, NAT and Host-only Adapter.

To recover, I have to shutdown the VM and disable and enable the wireless adapter from Device Manager. I am then able to see wireless networks. This does not work if the VM is running. When things are working properly, I don't have an issue connecting to the Internet either from my host or the VM.

I am running the latest version of this device, 12.0.0.722. I have the latest version of VirtualBox installed, 5.2.22 r126460. The power saving setting in my network adapter have been disabled (see step 3 here).

How can I stop this from happening?

2
  • Did you find a solution? I have this happening to my Dell g3. Jun 12, 2022 at 7:11
  • No. I originally thought it was an issue of the amount of RAM. When I increased the RAM from 8 GB to 16 GB and increased the RAM for the VM, the problem didn't happen for over 3 weeks, but then it started happening again. I ended up switching to Linux. Jun 12, 2022 at 13:29

2 Answers 2

0

It's most likely the drivers it's installed. I'd try uninstalling VirtualBox (copy the VMs to another directory if needed...), uninstalling all the drivers it installed, then reinstall everything (don't uninstall your Qualcomm Atheros' drivers, only the VirtualBox ones.).

10
  • I uninstalled VirtualBox, and the problem still happens when I reinstall it. After uninstallation, the 'VirtualBox Host-only Ethernet Adapter #3' was uninstalled. This problem makes working with VirtualBox difficult since I have to save the machine state to re-enable the wireless adapter, I lose my SSH sessions. Dec 29, 2018 at 4:26
  • OK... If need be, go online to Qualcomm's driver sites, and download your drivers, and reinstall them. If they don't work after this, then you may just have a faulty windows install... It's not your Wifi card.
    – Grizzly
    Dec 30, 2018 at 4:32
  • I reinstalled the Qualcomm drivers, and this problem still happens. It looks like driver doesn't work well with VMs. Feb 28, 2019 at 3:01
  • Hmm. Try going to your networking section in your VM settings
    – Grizzly
    Feb 28, 2019 at 3:16
  • Change from whatever to NAT (if not already on) and make sure the other 4 connecters are off/NAT
    – Grizzly
    Feb 28, 2019 at 3:16
0

If we use Lenove computer, we can try the following way to see if there is wireless adapter showing (because I have encountered the problem):

  1. Download and install Lenovo Energy Management according to the model of our computer on the official website of Lenovo.

  2. When it is completed, restart the computer.

  3. It will run automatically after restarting the computer after the normal installation is completed, but if it is not running automatically, we find this utility in the appropriate directory called Start_Utility and double-click it, then it will run( There is no hint after it runs, but we can find the process of utility in the process, it displays like utility.exe).

enter image description here

enter image description here

  1. Open the Lenovo wireless device setting module by pressing fn and f5.

  2. Turn on the wireless network card.

  3. View if there is wireless adapter showing.

1
  • I don't have a Lenovo, this problem still happens even though I have disabled the power managements settings of my wireless adapter. Dec 26, 2018 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.