1

UPDATE As for now, I am 100% the issue is my mouse. I connected another mouse and everything works just fine.

Here is the mouse I am using that doesn't work: https://www.amazon.com/Mad-Catz-Optical-Gaming-Mouse/dp/B00A72ZQK0

Any idea on how to fix this hardware issue?

ORIGINAL QUESTION

I am fairly new to the Linux world and installed Ubuntu.

My issue was, that clicking on popups did not work and most of the times the whole UI was not clickable. Strangely, while the UI was frozen, Websites in Firefox worked fine and I could use keyboard shortcuts like WINDWOWS + D or ALT + TAB without a problem. (Also the mouse cursor is movable and sounds play)

But I was basically unable to perform anything without encountering items I couldn't interact with or a complete freeze.

That's when I decided to install Linux Mint with the hope of getting rid of those problems. But against my hopes nothing changed. Same issues.

I figured out, that by unplugging and inplugging my mouse, the system works fine again, until after a few seconds or after I clicked some buttons, the UI is frozen again.

I am really frustrated now but don't want to switch back to Windows. I hope there someone who can help me with this.

Here are my system specs:

  • mouse and keyboard are connected through cable system

P.S.: I ran Ubuntu 18.04 LTS and now I am running Linux 19 Cinamon

0

I fixed the problem with the help of this site: https://wiki.archlinux.org/index.php/Mad_Catz_Mouse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.