0

I'm kind of a newbie linux user and have this problem where i need to install libsodium on my bluehost server. I'm using PHP 7.2.15, and you can see my current phpinfo() by visiting picklists.ca

I can't seem to get it to work. I've read a lot of posts on related topics nd can't seem to find a solution.

I connected via SSH to my server and ran the command:

yum --enablerepo=remi install php-pecl-libsodium

Which seems to have succeeded. I think I need to now install libsodium? I then tried running the command

sudo pecl install libsodium

and got the message "pecl: command not found".

I've added "extension=libsodium.so" to my php.ini file and restarted the server. I think the issue is obviously that the command "sudo pecl install libsodium" did not succeed, but i can't seem to get pecl to work. I've tried

yum install pecl

to try and get pecl working but it just says "No package pecl available."

Any help is much appreciated. Thanks

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.