0

I am running macOS High Sierra (10.13.6) and using Chrome (71.0.3578.98). I am a web developer and want to quickly activate the "Device Toolbar" via a keyboard shortcut so I can toggle between views for desktop and mobile.

When I have the DevTools window open on a site and hover over the icon that allows me to do this via mouse click it says there's a shortcut of Command+Shift+M.

enter image description here

However, whenever I press this key combination nothing happens. There is a similar key combination shortcut of Command+Shift+C that allows me to "Select an element in the page to inspect it" which works without issue.

I have removed and deselected any system-wide macOS shortcuts that would use this key combination. Similarly, I don't have any app-specific shortcuts configured in the system settings for Chrome that use this key combination. Finally, I have no other third-party app running which overrides or blocks this key combination.

enter image description here

Why isn't this working as expected?

  • Very odd. FWIW, I just tried this on my MacBook Air (2018) running macOS Mojave (10.14.2) and it works as expected. Not great comfort to you I know, but still it works on my setup. FWIW, I just have Chrome installed but I never really use it much at all past web-page testing. – JakeGould Dec 28 '18 at 18:41
  • Thanks @JakeGould yeah it's so weird. I have never had it work. I have a pretty basic install of software on my system with nothing crazy. It has bugged me for quite a while and today was the last straw. Hoping someone can chime in with help. – Art Geigel Dec 28 '18 at 19:56
  • 1
    Just for fun I decided to review my Chrome Extensions to see if there was anything that might be impacting it and to my surprise there was. I installed a "Mute Tab" extension a long time ago that I have since forgot about entirely. Within it's keyboard shortcuts section I had that key combination used to mute a tab. So annoyed and angry at myself! Posting my answer in case it helps someone else. – Art Geigel Dec 28 '18 at 20:07
  • 2
    Lol! Definitely post that as an answer. And for whatever it’s worth the lesson is basically: Review system settings and always double-check installed plugins. – JakeGould Dec 28 '18 at 20:10
2

This all boils down to a problem I created myself. I had installed an extension long ago that I had forgotten about—called "Mute Tab Shortcuts"—and the keyboard shortcut was set to Command+Shift+M. I reset it to something else and now the Chrome combination to activate "Device Toolbar" is working as intended.

enter image description here

If you're running into similar problems I'd suggest reviewing your Keyboard shortcuts within Chrome first at chrome://extensions/shortcuts

enter image description here

  • Great answer to a common—but often forgotten—issue. – JakeGould Dec 28 '18 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.