The vendor documentation for a hybrid SSD/HDD drive says to disable disk defragmentation because it undermines the algorithms that determine what portions of the conventional magnetic drive to store in the SSD portion.

Web searching shows that, these days, Windows 7 does not defragment SSDs by default. I had messed around with defragmentation settings on my computer perhaps years ago, and the information about not defragmenting SSDs by default was not readily available. It's not even clear that this has always been the behaviour of Wndows 7. Therefore, I wanted to check that I hadn't manually turned on defragmentation in the past. I used the administrator account to check several things:

(1) In services.msc, "Disk Defragment..." is disabled.

(2) Invoking Control Panel\All Control Panel Items\Performance Information and Tools\Advanced Tools does nothing

(3) Right-click the C-drive, select Properties, choose the Tools tab, and click the Defragment now... button -- nothing happens.

(4) Nothing happens when I invoke defrag from DOS command line.

Have I covered all the bases, or is there some other way that defragmentation could inadvertently be started?

  • rename the "defrag.exe" file to "defrag.exe.bak" in the system32 folder, now your bulletproof. You may have to boot from a linux distro to rename it. – Moab Dec 29 '18 at 14:18
  • Thanks, will try when I get home, using Administrator account and either Windows Explorer or Cygwin's Bash. – user2153235 Dec 29 '18 at 22:33
  • I chickened out. I descended into the messiness of Windows security and permissions in the past, got lost, and created side effects that I'm sure I'm not 100% aware of to this day. I also messed up ownership and permissions by pretending they were like unix file permissions using Cygwin. This time, the file renaming via the Windows GUI failed despite running Windows Explorer as adminisrator, and I'm too chicken to stray from that simple path of permissions and renaming. – user2153235 Dec 30 '18 at 2:25
  • Be sure it is disabled in Task Scheduler also. – Moab Dec 30 '18 at 17:26
  • Thanks! Found it in the Task Scheduler path "Task Scheduler Library\Microsoft\Windows\Defrag". Under the Triggers tab, there is only a weekly Wed 1am start time, but the Status column says Disabled. Would you like to post this as an answer? – user2153235 Dec 31 '18 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.