0

I just noticed that something was using up about 500KB/s of (down) internet connection in the background. After checking more in details, I found out that this was used by Firefox, with a connection to 185.42.204.42:443, which then switched to 52.223.195.225:443. Both are Twitch IPs.

I don't have a single Twitch tab opened. I don't have a single stream running in any of my Firefox tabs. And yet, somehow, Firefox is loading 500KB/s of Twitch data in the background.

Is there a way to disable all background activity in Firefox? Something like: when I close a tab, terminate it fully and immediately, like I've always expected it to behave in the first place? I tried searching but all I found was someone with an AVG issue there https://support.mozilla.org/en-US/questions/997796

Using Fx 64 on Windows 10 x64

4
  • Does this continue after restarting Firefox or after rebooting? – harrymc Dec 29 '18 at 19:22
  • No, it only continues as long as the current instance of Firefox is running. If I quit Firefox and reload it (tab restore is enabled), it's all fine then. – user14764 Dec 29 '18 at 22:09
  • Check if this also happens in Firefox Safe Mode. If this fixes it, then some add-on is the cause. – harrymc Dec 30 '18 at 7:03
  • Well I'm failing to reproduce this today, even without the safe mode... I guess that must be why I hadn't noticed it before. Although I'm pretty sure it already happened in the past, as I had noticed unexplained data use by Firefox which I just never took the time to dig into until now. – user14764 Dec 31 '18 at 14:52
0

I finally found the cause of this "problem": one of the sites I had in my always opened tabs was actually playing a Twitch stream silently in the background :x

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.