0

GNU screen is capturing my ESC key causing problems with vim.

Is there any way to change that behaviour in screen? I believe it enters the command mode however I can do that do that with C-a:

This is not the same as C-a which I have already mapped to something. I am literally talking about the escape key in the keyboard.

I tried maptimeout 5 from this question but that doesn't help. I think it similar to tmux where do the following fix:

set -s escape-time 0
0

GNU Screen was working fine. The following vim option was the problem:

set mouse=a

In general, such issues could be related to vim configuration as well. Try to use a minimal vimrc and see if the issue happens.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.