1

I recently finished setting up my Pi with Raspbian Stretch lite and configured the Wi-Fi successfully. I was trying to assign a static IP address to it, but all I can find are tutorials for LAN not over Wi-Fi connections. I was hoping to take the easy path and assign the IP through my router, but it doesn't have that option.

1

It is basically the same way you would do it for your ethernet interface, you simply need to use the name of your wireless interface (presumably) wlan0. In Raspbian stretch (lite), if you add this part to your /etc/dhcpcd.conf you should be fine:

interface wlan0
static ip_address=192.168.1.99/24
static routers=192.168.1.1
static domain_name_servers=192.168.1.1

Of course you need to adapt the IP-addresses to your specific setup.

3
  • Hey thanks for your answer, finally i decided to connect the pi directly to my router via ethernet, but now when i try to ssh into it im getting permission denied when typing the password... Any idea how to fix this without the use of a monitor?
    – Lebowski
    Dec 31 '18 at 12:46
  • 1
    Did you at any point activate ssh on your Raspberry Pi? Per default it is disabled.
    – oh.dae.su
    Dec 31 '18 at 14:00
  • Yes i did... now its all working smoothly.
    – Lebowski
    Jan 4 '19 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.