1

I run Google Drive File Stream (GDFS) and Google Backup and Sync (GBS) simultaneously on Windows 10. I'd like to have both in the Quick Access list at the left of the Windows Explorer window. But it always seems to revert to having GDFS and not GBS in the list.

To replicate:

  1. Have GDFS and GBS (Google Backup and Sync) installed and running.
  2. Right click on the Google Drive (GBS) folder anywhere in Windows explorer, and Pin to Quick access.
  3. Note that Google Drive does appear in the Quick Access list.
  4. (Optionally, unpin GDFS from Quick Access. This does not make a difference.)
  5. Restart Windows.
  6. Note that GDFS is (back) in Quick Access and Google Drive is not.

Has anyone gotten this to work? Is there a hack by which I can force the change?

  • I'm having this same issue and it is extremely frustrating. Please update this post if you figure out a solution. – Cory Jan 31 '19 at 2:42
  • What happens if you rename Google Drive while it's on Quick Access? – harrymc Jan 31 '19 at 16:37
  • You mean, rename the Google Drive folder? I can't normally; it's locked by the GBS process. If I kill GBS, rename the Google Drive folder, start GBS, “locate” the missing Google drive folder, then restart, it appears to work. I now have the GDFS folder and the “Google Drive foobar” folder in Quick Access. Of course, that's an ugly hack, unsupported (productforums.google.com/d/msg/drive/AclZI-4R4C8/KdPnGnT_AQAJ), and I'll have to reconfigure other things that are pointing to Google Drive. – Jacktose Jan 31 '19 at 22:34
  • Update. After doing the same thing to rename it back to “Google Drive”, the problem reoccurs. – Jacktose Jan 31 '19 at 22:48
4
+50

Solution 1 : Freeze the Quick Access bar

Apparently you are trying for the peaceful coexistence of two competing Google products, or trying to keep a product that Google considers as deprecated. In all cases, as the Google products have no parameter for achieving this, then some hacking is required.

I understand that you can arrive at the situation where both icons are in the Quick Access bar, only that this does not last beyond the next reboot. My idea then is to freeze this state of the Quick Access bar and stop Google, or any other program, from modifying it, hopefully without causing spurious warnings during boot.

Analysis

According to the Microsoft article Users can't access the desktop and other resources through Quick Access in Windows 10, the Quick Access bar lives inside:

%appdata%\microsoft\windows\Recent\AutomaticDestinations\f01b4d95cf55d32a.automaticDestinations-ms

Contrary to expectations, this is a simple file and not a folder.

The StackOverflow post Decrypt/Read/Modify “.automaticDestinations-ms” and/or “.customDestinations-ms” further explains that this is a Structured Storage file. This ancient format is actually a file-system-within-a-file. It is unknown why Microsoft went to all this just for the sake of a few icons. The same post lists the open-source OpenMCDF project as capable of reading and the basic editing of such files, but we won't be doing that here.

Procedure

I suggest the following (untested) procedure:

  • Set up the Quick Access bar to your liking
  • Copy the file f01b4d95cf55d32a.automaticDestinations-ms as backup (on NTFS so as not to lose permissions)
  • Right-click the file and choose Properties
  • Try first in the General tab to set the file as Read-only and OK. If this is not enough:
  • In the Security tab, click Edit and set Deny for Write. Do so for all the listed accounts, then click OK. You should not have any problem doing it, since you are the owner of the file.

You will need to undo it at any time that you would like to modify the Quick Access bar.

Solution 2: Rename Google Drive in the Quick Access bar

It seems like the Google Drive File Stream software searches for Google Drive by name, so renaming it effectively disables this search.

  • 1
    I tested setting that file as "Read-only" and my quick access folders persisted on reboot. Thank you! – Cory Feb 4 '19 at 16:43
  • @Cory: Thanks, happy to know that this does indeed work. – harrymc Feb 4 '19 at 20:05
  • @P1h3r1e3d13: Where are you? – harrymc Feb 5 '19 at 22:01
  • @harrymc I was snowed in! I'm testing it now. – Jacktose Feb 7 '19 at 1:00
  • Read-only worked for me too. It's hacky, but meets the requirements I set. Thanks, and enjoy your bounty. – Jacktose Feb 7 '19 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.