0

I have recently installed Fedora 29 on HP ProBook 420 G2, previously Windows 7. The installation completed with no known issues, however now when I try to use gnome-software to install any software, the installation begins and always reaches 54% before showing the notification

software_name cannot be installed as not supported

I can install the same software using the dnf command in terminal, but I would like, if possible, to be able to use gnome-software instead.

I have tried reinstalling gnome-software and packageKit, and also tried

sudo pkcon refresh force -c -1

But neither worked.
Ive tried googling around and can't find too much info (that worked) from the first few google pages. Any advice would be gratefully received.

Or is there a similar GUI application that performs the same as gnome-software?

  • Has Fedora been updated? If so, then try removing the gnome-software cache, ask.fedoraproject.org/en/question/95444/… – DrMoishe Pippik Jan 1 at 18:58
  • Thanks for your reply, yes first thing I did after installation was sudo dnf update, and I have tried removing gnome-software cache, not working – Eva Volnik Jan 1 at 19:12
  • Thanks for reply, until there is a solution I will use dnfdragora, its visually a disaster but at least it works. Thanks in advance for any future answers – Eva Volnik Jan 1 at 19:27

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.