2

I'm trying to install Fedora 29 next to OSX on my macbook air. I downloaded the image and verified the checksum. Then I formatted usb to OSX Extended Journaled file system, and created bootable usb using

diskutil unmountDisk /dev/disk2s2
sudo dd bs=1m if=./Fedora-Workstation-Live-x86_64-29-1.2.iso  of=/dev/rdisk2

However, when I start my mac from the USB with the option testing & installing Fedora, I get the following error

enter image description here

This is not the first time that I'm installing Fedora to my mac, but I was getting the same error before, but still the media allows me to install it if I directly try to install it without testing it, so what is wrong ? why am I getting this error ?

Edit:

As I've stated, the checksum is OK

grep '^SHA256' *-CHECKSUM | awk -F '[()=]' '{ print $4 "  " $2 }' | shasum -a 256 -c
Fedora-Workstation-Live-x86_64-29-1.2.iso: OK
1

This solved my problem;

You are encountering this bug because of the way OSX handles USB devices. You run the dd command, which wipes the drive and does all it's fun stuff. Now, what Fedora is looking for is the drive to just be as is once it finishes writing it. Unfortunately, OSX finishes the dd command and then immediately automounts the drive. This, of course, triggers a whole bunch of system indexing tools, writing countless amounts of hidden .whatever files. This, in turn, changes the drive as the dd command saw it. Therefore, the data sum that the Fedora media checker is expecting is not the same, as the drive's contents have been changed.

Truthfully, you are safe to just go to town without verifying the drive. Either that, or install Disk Arbitrator to block drive automounting and then run dd again....will work without a hitch.

Taken from here: https://bugzilla.redhat.com/show_bug.cgi?id=1282244

  • 1
    I thought most ISOs use a read-only filesystem (like iso9660), so mounting it still means no new files can be written... I guess Fedora doesn't – Xen2050 Jan 3 at 1:22
  • 1
    I just love it when software does what it thinks I want instead of waiting for me to tell it. BTW, since you're using dd, there's no point in formatting the USB first because dd doesn't pay attention to what's already there. – Joe Jan 8 at 4:04
  • @Joe Oh, I didn't know that. Thanks for sharing. – onurcanbektas Jan 8 at 6:36

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.