Ive been trying to install VS 2017 for a long time no but without success. When I run the installer I have to click continue and after that it just repeats the same process (downloading, verifying, downloading, verifying etc) till I get the error

Unable to download installation files. Check your internet connection and try again.

Ive tried many solutions which Ive stumbled upon. Here's the ones that ive tried:

  1. Disabling all anti virus programs & firewall
  2. Changing my DNS to Google's servers (
  3. Try to use the --noweb option while starting the setup file.
  4. Install the certificates from the setup file (right-click the exe > Properties > Digital Signatures, select the signature > Details > View certificate > Install certificate)
  5. Check if "CNG key isolation" is running: no, not running. Is this a problem?
  6. I am perfectly able to install vs_installer.opc from this link
  7. Did the following method:

    1: Fire up run, type "gpedit.msc" 2: Brows to the following location: "Computer Configuration>Administrative Templates>System>Internet Communication Management>Internet Communication settings" then find the entry "Turn off Automatic Root Certificates Update" and open her up and set it to "Disabled". 3: Get Windows to check for updates, it will appear to do nothing (unless of course you need to actually need download updates, in which case you'll have to update, sorry!). 4: Now try running the installer again, this fixed the issue completely and allowed Visual Studio to install without any warnings or issues.

  8. Did all the Windows updates

  9. Tried installing with a VPN
  10. Tried to install the offline version (without success, same story)
  11. Tried both VS 2017 community/enterprise and vs_buildtools.exe, all have the same error.

Someone that can help me out? Im getting really frustrated. Ive reinstalled windows like 2-3 months ago and on the previous install I was able to install VS without any problem.

  • What version of Windows are you using? Does your user have the correct permissions to install software?
    – Burgi
    Jan 3, 2019 at 16:35
  • Why exactly are you specifically disabling Turn off Automatic Root Certificates Update? By shouldn't be necessary considering the default behavior of that policy. You should provide the installation log it will have the exact reason the installation could not proceed. Instead of submitting a comment, just provide the relevant information, as an edit to your question.
    – Ramhound
    Jan 3, 2019 at 19:17
  • I got it solved! Apparently I didnt properly install windows updates, but after I restarted my pc and only did the windows updates it worked. @Ramhound I found that solution on this thread: answers.unrealengine.com/questions/746735/… - I reenabled it once again to prevent future problems :)
    – Pοlatic
    Jan 3, 2019 at 19:35
  • @Pοlatic - You should submit an answer instead of replying with a comment. You should indicate which update was necessary to resolve this problem.
    – Ramhound
    Jan 3, 2019 at 20:08
  • How do I submit an answer? On other threads I can see seperate answers instead of comments under the main question. This is my first time on stackexchange so sorry for my stupidity ;-)
    – Pοlatic
    Jan 3, 2019 at 21:02

2 Answers 2


Install the certificates from the setup file (right-click the exe > Properties > Digital Signatures, select the signature > Details > View certificate > Install certificate)


When I encountered this problem today I downloaded VS2019 installer from https://visualstudio.microsoft.com/vs/ (https://visualstudio.microsoft.com/thank-you-downloading-visual-studio/?sku=Community&rel=16). It succesfully launched and offered me to install Visual Studio 2019. Then I started VS2017 installer VS_Professional.exe and this time it started successfully and installed Visual Studio 2017. I don't know why this problem occurs, though, and why starting the installer of VS2019 helps. This looks like a bug.

FYI: the installation was performed on a clean up-to-date Hyper-V VMs with Windows 10 64-bit and Windows Server 2019 under administrator with all updates installed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .