I'm emulating Ubuntu using VMWare and I've upgraded it to last stable 10.04 version.

When I boot the system I get this error (below the Ubuntu logo):

"an error occurred while mounting /mnt/hgfs"

I made a screenshot: http://dl.dropbox.com/u/72686/mountError.png

So I have to click S to continue and the the OS seems to work well.


  • 3
    Maverick is Ubuntu 10.10, which is so new it's not even alpha yet. do you mean Lucid (Ubuntu 10.04)? if you really are testing Maverick, you should probably post this to the Ubuntu dev forums or Launchpad. – quack quixote May 8 '10 at 13:51
  • yeah I guess it is Lucid then. I just downloaded the last stable version from ubuntu website. – aneuryzm May 8 '10 at 14:24

I just had the same problem with shared folders on Ubuntu 10.04 under VirtualBox and found this post with a workaround. Hopefully, VMWare will have a similar solution.

First, comment out the share mounting line in /etc/fstab. It looks something like this:

SharedFolderName    /mount/path    vboxsf    rw    0    0

Then edit the /etc/rc.local file to add the mount point. It will look something like this:

mount.vboxsf -w SharedFolderName /mount/path
| improve this answer | |

As mentioned here, editing the /etc/fstab with:

.host:/ /mnt/hgfs vmhgfs rw,ttl=1,uid=my_uid,gid=my_gid,nobootwait 0 0

worked for me.

| improve this answer | |
  • Comment for Peiwang: I tried the method of editing the /etc/fstab with .host:/ /mnt/hgfs vmhgfs rw,ttl=1,uid=my_uid,gid=my_gid,nobootwait 0 0 but it still remains the problem. I still have to press S to continue. – Ivo Flipse Jun 15 '10 at 11:20
  • I'd say this is the most proper answer... the S error-message only means that the mount-point hasn't been configured properly. Just test manually once what mounts and use those parameters in fstab. Adding the concrete name of the share to the path with numeric uid/gid should make it work. – Martin Zeitler Mar 12 '13 at 15:04
  • to see what mounts: mount -t vmhgfs .host:/NAME_OF_THE_SHARE /mnt/hgfs – Martin Zeitler Mar 12 '13 at 15:39

I'm using VirtualBox to run Ubuntu virtual machine. I just had this error after doing an update on Ubuntu-10.04 and restarting.

I reinstalled Guest Additions (no need to uninstall on your own - just install it the same way you installed it the previous time) and the shared folders were working again. Did not need to do anything else.

| improve this answer | |

Have you tried reinstalling the VMware tools or running vmware-config-tools? It sounds like the Host-Guest filesystem kernel extension isn't loading at boot-time, and reinstalling/reconfiguring the VMware tools will rebuild your initrd image and allow the module to be loaded at boot time.

| improve this answer | |
  • yes I've run again vmware-config-tools. The configuration ended but still the same error. And I cannot drag and drop anything. – aneuryzm May 8 '10 at 17:17
  • What does dmesg|tail say? Post that as an edit to your question. – Josh May 9 '10 at 22:55

In my case, I managed to fix this problem by enabling the shared folders feature in the VMWare GUI.

If you want to use the shared folders feature, look at the top of the running VM window and go to Virtual Machine->Virtual Machine Settings->Options tab->Shared Folders, and make sure Shared Folders is enabled.

You might not want to use the shared folders feature, for example if the VM is untrusted and you don't want to give it access to any folders on your physical machine. If so, choose from one of the answers that modify the fstab to allow uninterrupted boot without the hgfs/Shared-Folders feature.

| improve this answer | |

Re-installing vmware tools can fix this problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.