0

I have some movies in matroska format. They have english subtitles in. The problem is I have to manually select those by either clicking V or selecting them from the context menu.

Now I've seen those threads:

How can I make VLC auto-select subtitles in an MKV file?

Can VLC be set to enable subtitles by default?

The first one suggests that I should set the Subtitle track ID option in VLC to match the subtitle track id from my movie. Fair enough, it works, but when I launch a different one - it doesn't.

The second one suggests using -1 for Subtitle track and Subtitle track ID and selecting English as a preferred language. Now, this is better as it works for most kind of files, but there is one problem: What if the subtitles are not named as English (i.e. they are just Sub track 1)? Well, then it doesn't work.

So my question here would be: Is there a way to modify those files (i.e. with mkvmerge), and by modifying I mean just changing the subtitles name (or language name - don't know how it works in matroska)? And if not - can I somehow make it work in VLC then?

  • 1
    I can't make it not play by default, for me it always plays the first subs track if the languages aren't specified. Try a settings wipe. – Tetsujin Jan 4 '19 at 8:27
1

You have two options:

1) You can change your settings in VLC by going to Tools > Preferences > Subtitles/OSD and set Preferred Subtitle Language as eng. It will make English subtitles as default.

2) You can use mkvpropedit in order to set all the English subtiltes as forced:

mkvpropedit video.mkv --edit track:s1 --set forced-track=1

For batch processing your files in the same folder, open a command line and type on Windows:

FOR %G IN (*.mkv) DO (mkvpropedit.exe "%~nG.mkv" --edit track:s1 --set forced-track=1)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.