1

I have a PC with the following specs:

  • Asus ROG Strix B350-F Gaming Motherboard
  • Ryzen 5 2600
  • 8GB DDR4 RAM
  • Zotac GTX 1060 6GB AMP! Edition

The problem is that I very rarely get the motherboard splash screen, and the PC goes directly to Windows after turning on. In Windows everything works normally.

Whenever I press DEL or F2 to access the UEFI, the monitor just stays on a black screen, and I'm left with no choice but to turn the computer off by holding down the power button. This problem also persists when trying to access the UEFI by doing a Shift+Restart in Windows 10.

Very rarely under unknown circumstances, I do get the splash screen, at which point I can press DEL or F2 to access the UEFI.

I strongly suspect that the UEFI is in fact booting when I press DEL or F2, but for some reason, the graphics card is not outputting any video when on the splash screen or in the UEFI. It only starts working after booting into Windows 10. In Windows it works fine.

I've tried the other DisplayPort ports on the GPU, and also the port on the motherboard itself, but no dice.

Did I correctly identify the issue, and how do I fix it?

0

Did you try resetting the CMOS RAM (using the jumper as stated in the motherboard manual)? This has saved me sometimes with BIOS and booting troubles.

0

Do you get the same result if you disable the graphics card and use the onboard/integrated graphics? If your Asus mother board is similar to my Prime Z270, you can remove the motherboard battery, short your jumpers* to reset CMOS and your will be forced to enter the BIOS on the next boot, where you can then check your UEFI settings and also increase the time to alter boot options.

*Remove the power prior to jumping the shorting pins

0

My Dell desktop had the same problem. Turned out to be the video card that I used from my old desktop. It was confusing the computer. If you unplug the video card and just use the video socket on the computer directly to your monitor, you'll get the splash screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.