3

My question is similar to How to permanently disable mouse integration in Virtualbox? except it's about VMware Workstation Player instead of VirtualBox.

How do I disable mouse integration? I want the VM to "capture" my mouse. One option is to pass my mouse directly to the VM, but that's more difficult if I need to exit the VM (I want to just use Ctrl+Alt).

I'm using "VMware Workstation 15 Player (Non-commercial use only)"

2

VMware Workstation Pro has checkboxes in its Preferences dialog to disable soft (motion) grab and ungrab, but VMware Workstation Player does not have any graphical UI to configure this. You can, however, manually edit your preferences file:

  1. Close all running instances of VMware Workstation Player and VMware Workstation Pro.
  2. Open the preferences file in a text editor. (On Windows, this file is located at %APPDATA%\VMware\preferences.ini; on Linux, this file is ~/.vmware/preferences.)
  3. Add the following lines:

    pref.motionGrab = "FALSE"
    pref.motionUngrab = "FALSE"
    

    (If pref.motionGrab and pref.motionUngrab lines already exist in the preferences file, change their values.) You now will need to click in the guest window (or press Ctrl+G) to grab and will need to press Ctrl+Alt to ungrab.

This will affect all VMs. To disable automatic mouse ungrab per VM edit the vmx file (with the VM turned off) and add a line:

mks.gamingMouse.policy = "gaming"

See https://communities.vmware.com/thread/398026 for other setting options.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.