0

I can’t enable Windows features through the Control Panel, features on demand, downloading them online, or through the Command Line or PowerShell. It fails with error code 0x80070002. I think it can’t find the files and I tried running a command to restore system files but after searching multiple sites I can’t fix it. I can provide any more information you need, I just need help activating these features. I have another computer which works fine so if I need to copy files over I can do that if you can tell me which ones. Thanks!

Edit: Thanks for the feedback . I will clarify some things. First, my Windows information is: Windows 10 Enterprise, Version 1803, OS build 17134.472. Next, I tried to turn both .NET 3.5 and Subsystem for Linux on through Windows Features and it still failed with error code 0x80070002. As for the command I ran, it was sfc /scannow

  • 4
    What build of Windows 10 are you using? Edit your question to include this vital information. I tried running a command - Which command? – Ramhound Jan 4 '19 at 17:53
  • What command did you use to attempt to install either of these Windows Feature? Edit your question. – Ramhound Jan 5 '19 at 16:55
0

Its because those are not in the Control Panel. they're in Windows Features and the install has changed for WSL a bit.

Just hit the Windows key and type Windows Features to get to them.

Windows Subsystem for Linux Installation Guide for Windows 10

https://docs.microsoft.com/en-us/windows/wsl/install-win10

  • I did go to the Windows Features through the Control Panel and by searching for it, my problem is when I try to enable any features, it gives me an error. I have tried to enable the same things on a different computer without any problems, so the issue is with this specific computer, not what I'm doing. – potatohotdog Jan 5 '19 at 17:24
  • OK, so, really an environmental issue. Can you reset the machine back to a previous date, or reset the machine holistically? – postanote Jan 5 '19 at 20:41
  • I can't reset the machine back, but how would I "reset the machine holistically"? – potatohotdog Jan 13 '19 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.