0

I have set the "NUKE_PATH" environment variable which is recognized and loads without issue when running nuke from an open terminal but when I submit a remote render job using RUSH, it is being ignored.

Even running Nuke in -V verbose mode from the terminal shows where it loads the environment variable and looking at the logs, that's being skipped when submitting remotely.

I have set the NUKE_PATH in the following 3 places:

  • /etc/environment (NUKE_PATH=/path/to/scripts)
  • ~/.bashrc (export NUKE_PATH='/path/to/scripts')
  • ~/.bash_profile (export NUKE_PATH='/path/to/scripts')

None of these are being recognized with a command line execution of a render but all work fine in the GUI.

Any help would be greatly appreciated.

0

Upon further experimentation, I found the best way to handle this wasn't at blade level in linux but rather at submission level with python. Setting ENV as part of the process with:

  • os.environ["NUKE_PATH"] = "/path/to/scripts"

fixes the problem and handles it in a more controlled and efficient way while also saving the hassle of having to set ENV on any of the host machines no matter what OS it is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.