I have an internet connection the following way : Internet Modem <-> FireWall(not a router, a firewall) <-> PC

Everything is setup so my pc has an external ip address, and my firewall takes care of blocking bad stuff.

I connect by VPN to an external network, so I added a new connection using Windows Xp's "New connection wizard" (the vpn client that comes with Windows XP), it's a PPTP connection so I used all default settings. I put the PPTP server's IP, my username and password and I succesfully connected. I was able to have access to the external VPN ressources.

The only problem is everytime I connect to this VPN, my computer cannot connect to the web anymore, no msn, no ping, no web.

Is there anything special I should be doing?

  • Now that you've found a way around this: make sure you understand the security issues. Connecting to both the VPN and the plain Internet simultaneously might be a risk. Also, if that VPN is work-related: your employer might actually forbid you to hack around that limitation. – Arjan Oct 14 '10 at 20:41

Most VPN software has an option to allow certain types of traffic to go through the local connection (rather than through the vpn). This saves on the amount of traffic going through the VPN. So look for something like "route non vpn traffic locally".

  • I know what you are saying, but this is with the vpn client that comes with Windows XP, I dont see that option... – Enriquev May 8 '10 at 16:45
  • I remember doing something like what I describe in XP because a corporate vpn i was connecting to rejected web traffic. – bryan May 8 '10 at 16:49
  • this might be helpful - support.microsoft.com/kb/317025 particularly - To resolve this issue, configure the client computers to use the default gateway setting on the local network for Internet traffic and a static route on the remote network for VPN-based traffic. I know it's a bit different in XP, but that was how i resolved it – bryan May 8 '10 at 16:53
  • Yay! I did step 2 on that page and now it works! Thank You! – Enriquev May 8 '10 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.