0

I have a MYSQL 8.013 server that was running fine till I was playing with a programme written by another coder and then all things came to a halt and the error message was the server does not recognise the password.

So, what I did was to pass all privileges to root user by following this advice from stackoverflow :

https://stackoverflow.com/questions/50177216/how-to-grant-all-privileges-to-root-user-in-mysql-8-0

And then I tried to re-configure MYSQL server via MYSQL windows Installer. I am using Windows 10.

But, the password that I typed is still not granted.

And I can't continue re-install mysql server from there.

I hope someone can tell me how to overcome the password error.

enter image description here

I have also tried the following the get error as follows :

C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin>mysql ERROR 1045 (28000): Access denied for user 'ODBC'@'localhost' (using password: NO)

C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin>mysqld FLUSH PRIVILEGES;

C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin>mysqld FLUSH TABLES;

C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin>mysqld -u USERNAME -p Enter password: ******** mysqld: Can not perform keyring migration : Invalid --keyring-migration-source option. 2019-01-06T13:47:23.770636Z 0 [System] [MY-010116] [Server] C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin\mysqld.exe (mysqld 8.0.13) starting as process 7696 2019-01-06T13:47:23.790797Z 0 [ERROR] [MY-011084] [Server] Keyring migration failed. 2019-01-06T13:47:23.851356Z 0 [ERROR] [MY-010119] [Server] Aborting 2019-01-06T13:47:23.862697Z 0 [System] [MY-010910] [Server] C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin\mysqld.exe: Shutdown complete (mysqld 8.0.13) MySQL Community Server - GPL.

C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin>mysqld --initialize-insecure --console 2019-01-06T13:48:30.472661Z 0 [System] [MY-013169] [Server] C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin\mysqld.exe (mysqld 8.0.13) initializing of server in progress as process 7148 2019-01-06T13:48:30.526721Z 0 [ERROR] [MY-010457] [Server] --initialize specified but the data directory has files in it. Aborting. 2019-01-06T13:48:30.549741Z 0 [ERROR] [MY-013236] [Server] Newly created data directory C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\data\ is unusable. You can safely remove it. 2019-01-06T13:48:30.566754Z 0 [ERROR] [MY-010119] [Server] Aborting 2019-01-06T13:48:30.575948Z 0 [System] [MY-010910] [Server] C:\Program Files (x86)\MySQL\mysql-8.0.13-winx64\bin\mysqld.exe: Shutdown complete (mysqld 8.0.13) MySQL Community Server - GPL.

  • I'm not sure windows runs mySql as the 'root' user, but as possibly a service account or your own logged in account - you'll need to grant permissions to those accounts.... and don't just run programs without understanding what they'll do. – djsmiley2kStaysInside Jan 6 '19 at 15:12
  • I have granted all users and the root. And I have also grant all privileges to all the Windows users by setting the permission level to all etc. – Karen Goh Jan 6 '19 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.