Using a Eee 900A netbook by Asus. By pressing Fn + F2, I can disable or enable the wireless chip on the netbook, a blue LED indicates the status. I've been able to connect to wireless networks just fine with this netbook. However, if the wireless chip ever becomes disabled, I have to reboot to get my network connection back. This generally happens when suspending. For some reason the LED will be off and I have to hit Fn + F2 for it to light up again. However, after doing so, Linux will not reconnect to the network. It simply changes the wireless status from "wireless is disabled" to "device not ready". Even worse, I've recently had issues with the chip being enabled at boot, thus making it nearly impossible to get connected.

I've searched around on-line but haven't found much of anything useful on this. This happens on all kinds of different distros including Ubuntu 9.10 Netbook, EeeBuntu 4 beta, Jolicloud and Ubuntu 10.04 Netbook.


I noticed this question is getting a lot of views. To give a quick update, I never did resolve this issue with the given distro's. However, I'm currently running Ubuntu 10.10 netbook edition and this issue has gone away.

  • What kernel versions are those distros? You could try to install a Vanilla Kernel, maybe this is a bug which has already been fixed. – Bobby Jun 8 '10 at 10:24
  • Current installed distro is Ubuntu 10.04 Netbook Edition with kernel 2.6.32-21-generic. I tried installing a new kernel like you said using the instructions here wiki.ubuntu.com/KernelTeam/GitKernelBuild but I ran out of disk space. :sigh: – Matt Molnar Jun 9 '10 at 3:33

I can confirm that WICD (in Ubuntu community repos: add community/universe repos in sources then apt-get install wicd) does recover from sleep and hibernate with Wireless Networking working more often than not on my machine. --But, it is not 100%, thus my visit to this web page. Pertinent details: Kubuntu 12.04 64-bit, Intel Core2 Duo, Intel 3945ABG.

The first thing I do on a new *buntu/Debian install is get rid of the stock networking utility and install WICD...

  • Almost perfect resuming on new i7 Lenovo E530 Kubuntu 12.10. It is rare when the wireless does not recover. – BradChesney79 Mar 12 '13 at 4:26

Sounds like a problem with the wifi module. A rmmod followed by a modprobe of the relevant module should fix it, but you may need to shut down NetworkManager first in order to be able to remove the module. Don't forget to report this issue in Launchpad.

  • Not sure exactly which module is associated with the wifi but it's an Atheros AR5001 chip. So I rmmod'd ath, ath5k, and mac80211 and then modprobe'd them back in. No change in availability. – Matt Molnar May 21 '10 at 2:05

In my experience, almost all of the network problems was caused by NetworkManager: can you try to remove it, configure manually your connections and then try again to start/stop the wifi? If it works, just purge Network Manager.

  • Did an apt-get remove on network-manager. Then used this site to manually setup wireless: wiki.archlinux.org/index.php/Wireless_Setup#Manual_setup Except I don't have dhcpcd so I used dhclient instead which seemed to work. Got an IP, opened firefox and confirmed. I then disabled the wireless with the hotkey, waited a bit, then re-enabled. Firefox doesn't work, tried dhclient again, says "Network is down". Tried ifconfig wlan0 up, says "SIOCSIFFLAGS Input/Output error". – Matt Molnar May 21 '10 at 2:00

For anyone still encountering this problem, I've found that using WICD instead of the default NetworkManager tends to be more reliable. I sometimes had NetworkManager continuously trying but failing to get a connection to my router (for no reason I could think of, other devices connected just fine), while WICD didn't seem to have a problem doing that. I haven't updated for a couple of distro's, though, so perhaps this has been fixed in more recent versions of NetworkManager.


Did you install using an "alternate" installation medium?
On my Eee PC 701, the alternate installer left behind a hard-configured /etc/network/interfaces, which prevented NetworkManager from automatically configuring the interface.

Commenting out the wlan0 entry in said configuration file did the trick for me:

#auto wlan0
#iface wlan0 inet dhcp

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.