1

Using vsftpd and filezilla, I can connect and view files and directories in a user's home directory. An empty directory is initially visible, but after I mount an ext2 volume to it, the directory disappears in my client.

I mount the volume with this command, which gives no output:

sudo mount /dev/sdaX /home/user/dir

I also tried mounting like this:

sudo mount /dev/sdaX /var/ftp/pub/dir
sudo mount --bind /var/ftp/pub/dir /home/user/dir

I can then view the files from the volume in my filesystem, but in both cases, the directory dir is listed in my ftp client before mounting, and disappears after mounting.

I tried with setting the ownership of the directory+files to both root:root and user:user and set the permissions to 755.

My vsftpd.conf file is configured as so:

anonymous_enable=NO
local_enable=YES
write_enable=NO
local_umask=022
connect_from_port_20=YES
chroot_local_user=YES
allow_writeable_chroot=YES
listen=YES
listen_ipv6=NO
pam_service_name=vsftpd
userlist_enable=YES
userlist_deny=NO

How come vsftpd won't serve the mounted directory?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.