I'm trying to install a Linux driver for my wireless network card (D-Link DWL-G510) on my Red Hat Linux 7.1 machine with a kernel. I downloaded the serial monkey driver from the sourceforge site and was able to successfully compile the rt73 module and load it into the kernel. The problem now is that everytime I issue the command ifconfig wlan0 up it keeps returning with the following error message: wlan0: unknown interface: No such device.

I'm at a loss as to what to do here. I specifed wlan0 as the alias for the rt73 module in the modules.conf and also tried to load the driver with the command modprobe rt73 ifname=wlan0 (this specifies the interface name according to the instructions packaged in the driver), but the error message still keeps coming up.

Is there something else I need to do in Linux to configure the wlan0 part or is the module not recognizing the wireless network card? It would be quite strange if it is the later since all information from the Internet is indicating this is the linux driver I should be using for mentioned wireless card.

  • 2
    what do you get if you try ifconfig -a
    – bryan
    May 9, 2010 at 2:19
  • It only shows the loopback interface (lo) and nothing else. What do you suggest I do now? May 9, 2010 at 2:43
  • have you tried ifconfig -add ?
    – bryan
    May 9, 2010 at 2:55
  • Do you mean "ifconfig wlan0 add"? That command returns "wlan0: error fetching interface information: Device not found". May 9, 2010 at 3:49

1 Answer 1


I suspect that modprobe is successfully loading rt73, as can be confirmed with lsmod but that rt73 is failing to attach to hardware as will be complained about in dmesg | grep rt73. The kernel will load the module so long as the kernel side of the module is happy, but if the module can't find its devices, nothing will happen.

If the driver has failed to attach, you've entered a world of pain, digging through various /proc files trying to find out where the device driver module should have attached but didn't. On my box, some PCI bus info happens to live in /proc/bus/pci/devices. But I'm running kernel 2.6.32 and can't even remember when I last saw a 2.4 installation. May the road rise up to meet you, may the wind be ever at your back, may you find the your missing address space...

  • The DWL-G510 was discontinued by the manufacturer about 3 years ago. Not that D-Link would or could help you, just community support for old cards falls off sharply, says the guy who just dug out an rt2500 based pcmcia card.
    – msw
    May 9, 2010 at 3:59
  • I issued the "dmesg | grep rt73" command and it came back with two lines: rt73:init<br> usb.c: registered new driver rt73<br> Is that saying that it is trying to register itself as a USB device? That's odd considering this is a PCI card. Besides that message I cannot seem to see that it is complaining about failing to attach to hardware. May 9, 2010 at 4:14
  • do you have a /proc/bus/devices? grep that for rt73, a quick surf of the rt73 driver that you are using shows that it does handle both USB and PCI; that registering message unfortunately doesn't indicate much more than it ran and hooked to something (probably the kernel side). I wish I could tell you I didn't spend an afternoon groveling through the driver code for my rt2500, but you've got the source, it's open ;)
    – msw
    May 9, 2010 at 5:10
  • Argh! I was hoping it would not need to come to a point where one needs to learn how to write linux device drivers and groveling through the code. May 9, 2010 at 5:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .