0

I remember that When I set up my Windows 7 Professional configuration, I blocked RDP access (if I remember correctly I said "no" to a question coming probably from firewall) when inbound RDP session was started the first time. Then I tried to unblock it but without any result. I have one Remote Desktop rule in the firewall Inbound Rules, specifying TCP protocol. I have no difficulties with outbound connections. The router isn't the source of the problem because even in direct LAN connection the effect is the same. What to do?

  • What version of Win7 are you using? – JohnnyVegas Jan 9 at 8:03
  • Professional with all appropriate service packs. – witrak Jan 9 at 9:29
  • add two rules - incoming and outgoing to port 3389 tcp and udp. 4 rules in total, then try it again. – JohnnyVegas Jan 9 at 19:11
0

Check if the remote desktop settings allow connection from remote:

  1. right click on computer -> remote settings -> check which option is enabled
    • it should be "allow remote connection....."
  2. Check the firewall rules in which zone the port 3389 is allowed in inbound connection

  3. Check if you computer had an IPv6 address, if yes probably your network interface are set to public zone.

To enable it with powershell (run as administrator):

  1. Enable Remote Desktop Connection:

    Set-ItemProperty ‘HKLM:\SYSTEM\CurrentControlSet\Control\Terminal Server\‘ -Name “fDenyTSConnections” -Value 0

  2. Enable Network Level Authentication (this permit connection only from client with NLA)

    Set-ItemProperty ‘HKLM:\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\‘ -Name “UserAuthentication” -Value 1

  3. Enable the connection trough the firewall:

    Enable-NetFirewallRule -DisplayGroup “Remote Desktop”

the above steps should enable and permit RDP connection to your computer

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.