16
  1. I have installed Windows 10
  2. I have installed Linux Mint Silvia and I have chosen a device for boot loader installation - sda.
  3. There is not Windows 10 in grub menu when the system starts
  4. I have booted via Linux Mint live USB.
  5. I Do step by step https://howtoubuntu.org/how-to-repair-restore-reinstall-grub-2-with-a-ubuntu-live-cd
  6. But it still no Windows 10 in grub menu
  7. I have booted via live windows 10 USB.
  8. With restoration tools, I have chosen the command line
  9. I have fixed Mbr by console command bootrec /FixMbr
  10. Ok, windows 10 is loading by there is no Grub.
  11. I have repeated steps 4 and 5
  12. There is no result

Also, I have tried to change grub config with this answer https://askubuntu.com/questions/661947/add-windows-10-to-grub-os-list#answer-977251 - But in this case, There is Windows 10 - but when I chose - I will recursively going to grub

And with this answer https://askubuntu.com/questions/661947/add-windows-10-to-grub-os-list#answer-890562 I have an error message when chose Windows 10 - There is no bootmgr directory

Thanks @Kinnectus for help

Also, I have tried

sudo os-prober

And getting

/dev/sda1:FreeDOS:FreeDOS:chain
/dev/sda2:FreeDOS:FreeDOS1:chain

And then I have tried

sudo update-grub

And getting

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.10.0-38-generic
Found initrd image: /boot/initrd.img-4.10.0-38-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Found FreeDOS on /dev/sda1
Found FreeDOS on /dev/sda2
done

Unfortunately - there is not Windows 10 in grub menu

Also, I have fdisk output.

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048  16779263  16777216     8G  c W95 FAT32 (LBA)
/dev/sda2  *     16779264  33556479  16777216     8G  c W95 FAT32 (LBA)
/dev/sda3        33556480 770219115 736662636 351,3G  7 HPFS/NTFS/exFAT
/dev/sda4       770220030 976771071 206551042  98,5G  5 Extended
/dev/sda5       770220032 976771071 206551040  98,5G 83 Linux

Partition 4 does not start on physical sector boundary.

There is an issue. Maybe the problem is with this issue?

Please, help me, I am stucking with this a whole day. I completely have no idea, what am I doing wrong.

22
  1. Boot to your Linux
  2. Open a Terminal window
  3. Type: sudo os-prober
  4. If the results identify a Windows 10 install, type sudo update-grub which will update the GRUB entries and add it
  5. Reboot your computer and test to see if Windows 10 is a new option to select.
  6. End of instruction.
2
  • 1
    os-prober IDs another OS, but not Windows, but the partition is there, undisturbed. What can I do to boot Windows? I beleve the problem is that Windows is hibernated, but if I can't login, how do I unhibernate it?
    – codenoob
    Jan 20 '20 at 13:46
  • os-prober worked great but grub menu was not showing. It took this: GRUB_TERMINAL=console and GRUB_TIMEOUT_STYLE=menu in /etc/default/grub. As always, don't forget sudo update-grub. Ubuntu 20.04.2 with MATE desktop (askubuntu.com/a/1230221/652884) Jul 11 at 17:58
0

Try Boot-Repair tool. It seems easy and working in most cases

See details in answer https://askubuntu.com/a/661954/728585

1
  • Why, how might it help without needing to click the link to see it for the part you got working? Jul 10 '20 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy