I am currently working on a script to process assets for a game. I am breaking down old assets and reorganizing them for a new format. The original images have transparent backgrounds already. When I append images back together there is a white background applied to part of the image.

Most sources say to just use -background "#FFFFFF" to turn anything white transparent. But some of my assets use white and if I use this then the asset is destroyed.

This is the First image I am merging with this Second image and here is the output of script

here is part of my script. I would like to just say -background none but that does not work. How can I create an image without adding a background?

convert output3.png output4.png -append output6.png
convert output6.png output5.png -append output7.png
convert output7.png space.png -append -background none output8.png
  • Hi Andrew, I don't experience what you say. Please notice that the parameter is none, you typed nune. I downloaded your first and second pics and got a good output using convert first.png second.png -append -background none output.png – Jorge Valentini Jan 9 at 19:36
  • Damnit. Haha. Well fixed that typo but now I am getting the same problem but it has a black background instead of white... – Andrew Pullins Jan 9 at 22:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.