0

I ran Ubuntu 18.10's Recovery Mode and fsck failed saying dev/sda7 is mounted. I tried unmounting it only to be told that "it is busy". I'd appreciate any hints on solving this.

The partition dev/sda7 is actually the partition where Ubuntu is installed. EDIT: If it has any relevance, I'm using an SSD.

  • Boot from an USB drive and then do the check. – davidgo Jan 10 at 0:43
  • I already tried that using Ubuntu Live USB (my bad, I didn't mention it), but I couldn't run fsck because it said that the drive is 'in use'. I also tried unmounting the drive's partitions, but it still reported the same error. I wonder if there's actually a recovery mode for the Ubuntu Live USB. – PhantomR Jan 10 at 0:55
  • Try an alternative rescue disk designed for recovery. – davidgo Jan 10 at 1:00
  • Could you please suggest me one such disk? – PhantomR Jan 10 at 1:21
  • First one that springs to mind is trinityhome.org (for TRK), followed by SystemRescue at system-rescue-cd.org but look at fossmint.com/linux-rescue-recovery-tools – davidgo Jan 10 at 3:04

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.