7

A couple weeks ago, "Skype for Business" started popping up when I logged in. I opened its settings and unchecked Tools > Options > Personal > [] "Auto start when I log on to Windows" and it stopped for a week. Now it's doing it again, even though it's unchecked.

5
  • Using a program called AutoRuns, verify there isn't an entry for this application if this is a company/corporate computer you should contact your system administrator for assistance instead.
    – Ramhound
    Jan 10 '19 at 4:11
  • 1
    If you don't need it, you can uninstall it. Jan 10 '19 at 4:13
  • Is this a work computer? If it is, then you should ask your local IT people. If it is not, then Skype for Business may have installed as part of your Microsoft Office install and you can remove it by modifying the Office install. Jan 12 '19 at 0:52
  • @music2myear thanks for the reminder... that was strictly my mistake, and I removed my vote accordingly. That being said, obviously it would be nice to hear some feedback from the OP. Even on a domain, if you uncheck that option box or disable it within the Startup tab in Task Manager, that should suffice. Unless a newer version is pushed out via SCCM (or something similar), it would be exceedingly rare to override the end-user's preferences.
    – Run5k
    Jan 14 '19 at 19:52
  • Yea, not sure what accounts for the week gap before the persistence was enabled again. That long doesn't seem likely to mean GP or SCCM. More likely a patch or something. Jan 14 '19 at 23:12
5

Neither of the suggestions in the other answers worked for me.

The instructions at https://it.cornell.edu/skype-win/turn-auto-start-or-skype-business-windows seem more targeted.

By default, Skype will start automatically when Windows starts. You can change this setting.

Run Skype for Business.

  1. Click the gear icon to open the Options dialog box. (If you click the arrow next to the gear, you will need to select Tools, then Options.) In the list on the left, click Personal.

  2. On the right, under My account, you'll see a checkbox for Automatically start the app when I log on to Windows.

  3. Check this to have the app start automatically.

  4. Uncheck this to prevent the app from starting automatically.

  5. Click OK.

I tried it and the suggestion worked.

3

If people are still having this issue with Skype for Business loading at Windows 10 startup, and it is part of your Office installation, and you can't change the config within Office, then a rather inelegant method is to find the Skype for Business executable (lync.exe) which is stored in C:\Program Files (x86)\Microsoft Office\root\Office16 and rename it to lync.exe.old. That's it - problem fixed.

1
  • +1, was trying to solve this problem for someone and this was the only solution that worked. Oct 22 at 13:49
1

Make sure you have installed the latest update. If the issue still persists, try the following steps:

  1. Open Task Manager> Startup> disable Skype for Business from the list.
  2. Go to the location and remove Skype for Business if it is existing: C:\Users\username\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

Hope these are helpful.

1

If this is a work computer, policies may be changing these settings and you should ask your IT people about this.

If this is a personal computer Skype for Business may have installed as part of the Microsoft Office install, and you can remove it by modifying Microsoft Office.

Open Settings > Apps, find Microsoft Office and modify it, deselecting Skype for Business at the appropriate point in the process.

0

Funny thing I managed to rectify this annoying issue by making sure I unclicked the Skype for Business options to auto start when windows comes up, deleting my sign on id/password AND BY NOT EXITING BY SELECTING FILE/EXIT BUT RATHER GOING INTO TASK MANAGER AND KILLING THE SKYPE FOR BUSINESS PROCESS.

This did the trick. I also managed to replicate the scenarios. I started Skype for Business and then again, it would come up when windows started. Then I repeated the steps I mentioned above and it fixed the problem.

I hope this works for all of you!

0
  1. The solution which uses the flags within Skype for Business only works if there is an account associated with Skype for Business. I have no such account, and setting those flags does not work.
  2. The solution that says to remove it from the Startup list does not work because it is not in the startup list. I suspect it is started from somewhere else, or some other application (such as Office).
  3. In my case C:\Users\username\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup does not contain the start for lync.exe so that solution fails too.
  4. The last suggestion of actually killing Skype for Business from the task manager has actually succeeded. As my Skype for Business was already in the state that Theo moved to it solved my problem. 5 stars *****
0

use the following batch file to delete skype form user's profile and program data folder

SET ProfileBase=%SystemDrive%\Users

for /f "tokens=*" %%a in ('dir /b /ad %ProfileBase%') do @del /q "%ProfileBase%\%%a\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup\Skype for Business 2016.lnk" 2> nul

del /q "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\StartUp\Skype for Business 2016.lnk"

  SET ProfileBase=

exit /B %errorlevel%

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.