0

It is a new install. After installing node.js, Java, I run appium-doctor and got these warnings.

WARN AppiumDoctor  ✖ opencv4nodejs cannot be found.
WARN AppiumDoctor  ✖ fbsimctl cannot be found
WARN AppiumDoctor  ✖ applesimutils cannot be found

How to remove them?

When installing opencv4nodejs (npm i -g opencv4nodejs) it throwing:errors.......

ERR! Error: Command failed: cmake --version /bin/sh: cmake: command not found

npm ERR! code ELIFECYCLE npm ERR! errno 1

npm ERR! opencv-build@0.0.16 install: node ./install.js

npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the opencv-build@0.0.16 install script.

  • Can you give us a little more detail? Was this working and suddenly started throwing errors or is it a new install and it's done this from the start? Where did you get it and how did you install it? Have you checked for whether and where those files exist? – fixer1234 Jan 10 at 7:39
  • It is new install. After installing node.js, java, i run appium-doctor and got these warnings. When installing opencv4nodejs (npm i -g opencv4nodejs) it trowing errors.......ERR! Error: Command failed: cmake --version /bin/sh: cmake: command not found npm ERR! code ELIFECYCLE npm ERR! errno 1 npm ERR! opencv-build@0.0.16 install: node ./install.js npm ERR! Exit status 1 npm ERR! npm ERR! Failed at the opencv-build@0.0.16 install script. – Ravindra Somvanshi Jan 10 at 7:50
  • You've posted two answers but they don't appear to be solutions to your problem. If those are just progress updates, all of that information needs to be incorporated into the question. Answers are reserved for solutions, so two self-answers seems to indicate that you no longer need any help. – fixer1234 Jan 13 at 0:46
0

For:

WARN AppiumDoctor ✖ fbsimctl cannot be found

# Get the Facebook Tap.
brew tap facebook/fb
# Install fbsimctl from master
brew install fbsimctl --HEAD

WARN AppiumDoctor  ✖ applesimutils cannot be found

brew tap wix/brew
brew install wix/brew/applesimutils

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.