0

I need some help in turning off/disabling the touchpad edge swipe gestures in my Windows 10 2-in-1. When I swipe from the right, it brings up the Action Center. When I swipe from the left, it brings up the open processes. When I swipe from the top, it brings up the voice dictate mode. I want to disable all of those behaviors but my touchpad is detected by windows as a generic HID-compliant mouse.

Everywhere I look, the default response is to install the proper drivers but the proper drivers are indeed already installed. It's just that my 2-in-1 device uses a generic touchpad so there's no hope of ever finding a feature-full driver for it like with Synaptics, etc.

So now I want to find another way to disable the gestures. Can I hack around in the registry? Can I catch those system calls so they don't execute? Anything else I can do besides "finding the correct driver" because I feel like that's just an exercise in futility.

-1

Try the following way:

  1. Enter regedit in the Cortana search bar and press Enter to enter the Registry Editor.

  2. Position to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\EdgeUI

Note: Users without the EdgeUI item need to be manually created. Right click on Windows, select New, and rename to EdgeUI.

  1. Create a new DWORD (32-bit) value in EdgeUI, rename it to AllowEdgeSwipe, and keep the value data as the default "0".

  2. This modification takes effect after restarting the computer. To restore the above edge swipe gesture, change the AllowEdgeSwipe value data to "1" and restart the computer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.