I'm trying to install Android x86 on my Lenovo Miix 310. I made a bootable USB, entered setup mode in the device and booted the USB.

I can see the menu on which I can choose from live, live debug, installation, advanced and Windows. The menu is display ing just fine.

I load live just to see if it works. Everything is great, I have picture, sound and Wi-Fi. But while the live was loading, I couldn't see the usual text like "Loading /kernel" etc. but just some dots and hyphens.

Everything looked okay, apart that loading so I tried to install it. Again, while the installation was loading, I couldn't see the usual text like "Loading /kernel" etc. but just some dots and hyphens. After that "loaded", I could see a blue background and some text, but it was duplicated horizonatally and vertically, it was wrongly orientated etc. I couldn't read anything from it.

I've seen some sites saying how to adjust screen resolution and hardware acceleration by editing a file in debug mode. But guess what happened again - I couldn't see the usual text like but just some dots and hyphens.

More technical data:

  • Tablet: Lenovo Miix 310-10ICR
  • Tablet storage: 32GB eMMC
  • Tablet screen resolution: 1280 x 800
  • Tablet operating systems: Windows 10 x64, Phoenix OS (I want to remove both and only keep Android x86)
  • Installation media: 16GB 2.0 USB
  • Installation software: UNetbootin
  • Android x86 version: "android-x86_64-8.1-rc2.iso" (latest)

Any idea would be really appriciated.

P.S. I tried installing Phoenix OS and there were no issues, but I don't like the launcher and the ads...

EDIT: I (think that I) can confirm that the issue is the screen resolution. Later into booting live, the display fixes, but that doesn't happen when installing. A driver issue?

EDIT 2: I tried using an online tutorial as a reference to install as I can barely see something, but like five seconds in the installation and then the screen turns blank.

EDIT 3: Seems like a known issue with newer BIOS: https://www.bios-mods.com/forum/Thread-REQUEST-Unlock-BIOS-for-Miix-310


Yep, the BIOS was the issue. Flashing "1HCN30WW" as stated here: https://www.bios-mods.com/forum/Thread-REQUEST-Unlock-BIOS-for-Miix-310 fixed the display.

Just be sure to enable BIOS back flash in BIOS to be able to install the old one.

Also, if you get a blank/black sreen at some part, use "nomodeset" as stated here: http://www.android-x86.org/documents/how-to-boot-the-android-x86-live-cd-when-you-have-problems-with-your-graphiccard.


Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.