0

I ran TCP throughput from client(iperf -c IP -i1 -p19223) to server(iperf -s -i1 -p19223).

The stats showed me bandwidth of ~5Gbps. However, when I ran iptraf on the server, I came to know that iperf was showing wrong statistics. The actual traffic the server was receiving was only around 600Mbps.

iptraf is not showing wrong stats because I have also run the iperf command (on client side) with the bandwidth mentioned. When I gave the bandwidth 1Gb(1000m), I could only receive around 600 Mbps(same as shown in iptraf in both the cases). Only when I didn't mention the bandwidth, I saw this issue. Really strange.

Is this a known issue?

Server/Client: RHEL 6
Iperf: iperf-2.0.5-11.el6.x86_64.rpm
  • 1
    Are you sure iptraf isn't showing wrong statistics? – grawity Jan 11 at 14:17
  • Please see the question details. – Vishal Sharma Jan 14 at 9:57

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.