0

I have a web server setup on a device which has the IP address

192.168.2.12

I can connect to this IP via the same network, however, when I try to connect to my public IP and port forward to this IP, the browser fails to load. The error - ERROR

Settings

  • Forward port 80 to 192.168.2.12 using TCP
  • Forward port 443 to 192.168.2.12 using TCP

Settings

My public IP is

123.201.94.235 

So I tried connecting to

123.201.94.235:80
123.201.94.235:443

But both failed.

Note that when I ping

123.201.94.235 

the router replies.

What am I doing wrong?

  • Are you testing the connection from inside or from outside the LAN? – grawity Jan 11 at 17:09
  • @grawity I have tried both. None work unless I use the internal IP (which can be used only from inside the LAN) – Holyprogrammer Jan 11 at 17:10
  • Then focus first on getting connections from outside working; those are the simplest case. Port-forwarded connections from inside are very problematic (see also, see also, see also, see also) – grawity Jan 11 at 17:17
  • It might be somewhat helpful to know the make and model of your router. Are there any other routers or firewall appliances in front of this router which traffic from the outside world will need to hop across to get to the server you are forwarding the traffic to? If this your Internet router or is your Internet router just a bridge with no rules or what? – Pimp Juice IT Jan 12 at 7:37
  • @PimpJuiceIT I use a belkin router, and there are no firewalls except the one that comes with the router built-in – Holyprogrammer Jan 12 at 12:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.