I have a few computers connected through a Gigabit router which show 1Gbps connections. However, one of the computers only shows 100Mbps connectivity even though it is capable of 1Gbps. I am not seeing any errors in the event viewer.

Computer Specs

  • Windows XP SP3 x86
  • A8N-SLI Premium MoBo
  • AMD Athalon Dual Core 4400+ CPU (4gigs RAM)
  • Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller
    • Driver: Marvell v11.24.3.3 (2/15/2010)

Networking Specs

Question 1: How can I configure the above computer/Ethernet Controller to run at 1Gbps connectivity like the others?

Update with 2nd Question

Question 2: If I were to use the onboard NVidia nForce Networking Controller (currently disabled), which driver should I use the NVidia nForce4/500 series - Windows 2000/XP v6.86? (I have an nForce 4 Mobo). NVidia nForce archives:


If you've tried forcing the driver to connect at GigE and it fails, you may have a bad (or poor quality) cable.

You indicate you have other computers that work at GigE; try swapping the cable on the nonworking computer with one from a working computer. Try again with the driver set at auto-negotiate and at 1000Mbps. If it works, replace the bad cable.

Metro Smurf was able to determine the wall jack was faulty. When troubleshooting a wired network, every cable, jack and port is a potential point of failure. If possible, swap everything:

  • swap the cable with a known-good cable (PC -> wall jack);
  • swap the cable into a known-good port (in the switch or router);
  • swap the PC to another wall jack;
  • swap another PC to the suspect wall jack;
  • connect PC directly to the switch or router.

Eliminate as many individual links as possible. -- in this case, connecting the PC directly to the switch/router with a known-good cable was found to work, while connecting through the jack with the same cable failed.

  • All the cable was hand rolled and came from the same spindle. I've tried using a couple of different cables, but the connectivity stays at 100Mbps. Maybe the Marvell Yukon isn't really able to run at 1Gbps? Or my configuration of the Yukon and my chipset is faulty? – Metro Smurf May 9 '10 at 18:04
  • @Metro: ok, so it's not the cable. hmm. i'm unfamiliar with the chipset, but it's possible that it's not really GigE capable; it's also possible that your chipset (or chipset+driver combination) has trouble with the router or switch it's connected to. have you swapped ports to eliminate the router/switch port as a suspect? – quack quixote May 9 '10 at 18:29
  • Yep, swpped ports and used the known good cable/port combo. I'm not sure why I disabled the nForce network controller (there was a reason a few years ago). I'll give that one a try again, but will need to install the driver first. (any recommendations on which driver I should use? see edited question). – Metro Smurf May 9 '10 at 18:33
  • @metro: given that you're using XP SP3, i'd try the latest XP driver first (looks like v6.86), NOT the Vista driver. – quack quixote May 9 '10 at 19:31
  • 1
    I decided to start from scratch with the trouble-shooting and have concluded that the rj45 jack has become corrupted. I did a direct connection from the switch to the computer with an old cat5 cable and picked up a 1Gbps connection (both controllers connect at 1Gbps). Then used same cable from rj45 jack to computer and was back at the 100Mbps on the Marvell port, but unable to even connect with the NVidia port. Looks like I need to re-do the jack. Thanks! – Metro Smurf May 9 '10 at 19:41

Check the System -> Hardware -> Device Manager in the Control panel. Select the networking device (marvell) and check the settings at the special tab. You can set up the speed and other parameters as well.

It's like this for me (this is Windows 7 but it's the same in XP):

enter image description here

  • The properties was set for auto-negotiate. When I set it to 1000Mbps, the connection pukes and will not renew (used ipconfig as well as using the network panel to enable - both failed). And in the event log I get this event: The system detected that network adapter <snip> was disconnected from the network, and the adapter's network configuration has been released. If the network adapter was not disconnected, this may indicate that it has malfunctioned. – Metro Smurf May 9 '10 at 17:50
  • Hmm hmm. Strange for sure. What about a different network adaptor? Can you try a different one? (Maybe you can exchange two cards like one works in pc A , one works in pc B. (it is NOT uncommon :)) – Apache May 9 '10 at 20:16
  • Ah I see that the problem is solved the cable was the problem. I thought you already closed out the 'cable factor'. >.<" – Apache May 9 '10 at 20:36
  • Thanks for your help Fujishiro - the problem ended up being a faulty rj45 jack. I too thought I ruled out the cable problem... and I did, but never thought to test the actual wall jack. – Metro Smurf May 9 '10 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.