5

I'm unable to login to my Plesk control panel, or even pull up the page.

Plesk's repair utilities fail to work, so web/GUI methods seem to be entirely unavailable.

The only way I can login is via command:

mysql -u admin -p [entering correct password]

But Plesk itself cannot connect to MYSQL 5.7, because it's using whatever the old password was.

How do I update the password that Plesk uses to connect to MySQL?

New contributor
user10902472 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
4

Pointers for updating the Plesk MySQL password

  1. According to the "The Plesk shows the error: Cannot connect to MySQL 4.1+ using the old insecure authentication" post, you can go to Plesk > Domains > example.com > Databases > User Management > database_name and in the the new window submit the new password.

  2. Additionally, according to the "Plesk is not accessible: Access denied for user 'username' @'localhost' (using password YES)" post, you can run plesk sbin psadb -u --password="password" with the new password from command line.


Additional Resources & References

  • I have some feedback in my own answer, but thanks for giving me the route to the right track. Your first option though was unavailable to me because I couldn't access the plesk website to begin with. – user10902472 Jan 11 at 21:18
  • @user10902472 I'm glad I could help and that you were able to get it resolved. Thanks for sharing the updated and explicit detail from your answer too. This may save others a headache or two in the future which we helped contribute to. – Pimp Juice IT Jan 11 at 21:20
3

Following the instructions on a link shared by Pimp Juice's answer, Typing plesk db gave me the error: ERROR 1045 (28000): Access denied for user 'admin'@'localhost' (using password: YES)

The solution was to combine the two, as I can't find a documented way that plesk db allows username and password options

  1. Run mysql: mysql -u admin -p MyMySQLAdminPassword, which is what plesk db was trying to do with the credentials it knows.
  2. Paste the command UPDATE mysql.user SET authentication_string=PASSWORD("MyMySQLAdminPassword") WHERE user='admin';
  3. quit MYSQL
  4. Run the command: plesk sbin psadb -u --password="MyMySQLAdminPassword", quotes included.
New contributor
user10902472 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

user10902472 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.