0

I had windows 10 preinstalled on my system with boot type UEFI mentioned in my lenovo ideal pad boot options. I dual booted with linux mint tara which worked fine with grub loader showing both the OS entries. Later on i decided to delete linux partition which happened to be the system FAT32 partion on which efi bootloader was installed i suppose . to get rid of grub i deleted the EFI dir from windows . Now i am not able to boot into windows as it is on a boot loop keeps saying System BootOrder not found. reSet to default. Help !

  • What is the manufacturer/model of your BIOS? Do you have access to the BIOS settings? – GreenJames Jan 12 '19 at 22:12
  • yes i do have access to BIOS settings. Boot is set to UEFI even ,legacy support option dint work cuz hdd is gpt so no mbr. on reinstalling linux grub is showing up windows bootloader which is booting to wimdows fine. but when i remove ubuntu entry from EFI partition boot option it goes back to same problem. All i want to convey here is that UEFI loads grub well but not windows bootmanager alone. – user3899994 Jan 13 '19 at 6:24
0

The \EFI folder contained subfolders for both the Mint GRUB2 bootloader and the Windows bootloader – and you deleted both. To reinstall the Windows bootloader, use bcdboot:

  1. Boot from the Windows 10 install CD or USB. Make sure you boot it in UEFI mode (the firmware might have two very similar boot choices).

  2. Choose the "recovery console" option. (I don't remember what the menu item is called, exactly, but ShiftF10 should open it anyway.)

  3. Use dir c:\, dir d:\, etc. to find your main Windows partition (with the \WINDOWS folder).

  4. Once you know the correct drive, run bcdboot c:\windows (replace c: with the correct letter).

  • thanks for the answer but tried the option already but no luck . C :\ is the drive letter for me , what i have learned so far from my research on the topic . the EFI looks for the system partition with FAT32 fs for the bootloader which is D:\ in my case where linux resided previously and EFI entries as well. Now that i have run bcdboot i have EFI on C: and D: as well with boot and Microsoft/Boot sub folder and both have bootmgr.efi in it but still somehow EFI firmware is not able to load it. I have Hiren's BootCD win10 live USB with bootice and easybcd – user3899994 Jan 12 '19 at 10:08
  • if you know how to tweak with this please let me know – user3899994 Jan 12 '19 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.