0

I want to securely erase my C: drive, a Toshiba XG5 NVMe 512GB SSD, without wearing it with deletes. I know SSDs can be zeroed directly by resetting the NAND cells, and manufacturers like Samsung have applications to do that. So ideally that is what I want to do, but I can't find one for Toshiba SSDs.

Alternatatively I could rely on TRIM plus overwriting the entries of deleted files in the NTFS MFT. That could serve as a kind of secure delete, and I wouldn't have to reinstall Windows.

Maybe I could try this. (1) Make a Windows RE rescue USB. (2) Install the secure erase software on it (if that is even possible) (3) run it from the USB

Or maybe this. (1) Make a Linux boot USB to boot into Linux on the USB. (2) Use hdparm to do an ATA secure erase.

I haven't done anything like this before. Can anyone advise me?

Is there a utility that will overwrite the entries of deleted files in the NTFS MFT, without also writing all over the disk in a free space wipe as though it was an HDD? And sanitize the NTFS logs & journals too?

  • Encrypt the drive, format it. Done. Keys gone, recovery impossible. – Tetsujin Jan 12 at 19:08
  • @Tetsujin assuming a full disk encryption is performed and not just a limited encryption of currently “used” space. blogs.technet.microsoft.com/tip_of_the_day/2013/12/05/… – Appleoddity Jan 12 at 19:12
  • Possible duplicate of How to securely delete files stored on a SSD? – Moab Jan 12 at 19:26
  • C: is not a drive. It point to a filesystem. Usually a filesystem in a partion on a drive. That can come down the the same (one drive with one partition and one filesystem), but the same drive might have multiple partitions (e.g. C:, D:, E, unmount ESP partions etc. In which case you want to secure erase the drive and not the filesystem C: (hint: there are bootable CDs/USB out there which do a secure erase) – Hennes Jan 12 at 19:54
  • Bitlocker hardware drive encryption is broken - assume anyone with access to the drive can decrypt it. Software encryption makes disk access too slow. So disk encryption is non-viable until the manufacturers fix it. – Moonling Jan 12 at 21:51
1

Rewriting the entire disk is not recommended for an SSD, and is anyway not required, since most modern SSDs have the ability to secure erase the entire disk in one giant TRIM operation.

Toshiba does not furnish such a utility for your disk, so you need to use a third-party solution.

Here is one such free solution:

  • The free AOMEI Partition Assistant Standard secure erase function does not work in Windows 10, just Windows 7. I installed it and verified this. I do not have a Windows 7 PC, so I can't use this software. – Moonling Jan 13 at 8:46
  • Sorry, the documentation was misleading : Secure Erase is limited to the paid version. I replaced it by other products which advertise as being free. – harrymc Jan 13 at 9:45
  • Can you say which free product is able to secure erase a SSD by zeroing the cells directly and not overwriting? – Moonling Jan 13 at 11:26
  • After check, it seems like only Parted Magic is left, and this also is based on an obscure text on the website: "When Parted Magic Secure Erase is issued against a SSD drive, all of its cells will be marked as empty". I take it to mean that it will use TRIM rather than write zeroes, – harrymc Jan 13 at 11:52
0

I succeeded without using a paid-for tool. A TRIM of the drive resets the flash cells of deleted files after a while - it does it in idle processor time. So the only remains is the file metadata in the NTFS Master File Table. There is no application available that will sanitise (in practice by overwriting the entries) the MFT without also writing to all free space on the disk, which I explicitly rule out. So I re-installed Windows. You get a new MFT and can keep your existing files. It took several hours of software installation and tweaking to get it back to the way I like it, but job done. I verified the result by running a quick scan in Recuva then a deep scan. The quick scan looks at the MFT and the deep scan does a low-level read of the whole partition.

  • I also tried booting into Linux on a USB stick in order to do an ATA secure erase with hdparm. This might have worked and would have meant the whole drive was zeroed and would have to be formatted. I failed because I couldn't get Linux to see the internal SSD. Later I found out how to do this but by then I had already implemented my solution above. – Moonling Jan 15 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.