0

My laptop:

  • HP x360 Convertible 13
  • Intel i7-8550U
  • Windows 10 Pro
  • a Synaptics “Clickpad” touchpad

When I first got this laptop, there were numerous problems with the touchpad: it was sluggish and erratic, and clicking, particularly right-click, was unreliable. Searching the Internet turned up suggestions to install Synaptics’ own drivers rather than the HP-supplied driver, which I did, and it solved the problem for months.

Then yesterday morning I woke up to find that my computer had restarted (probably Windows Update), and moreover, my mouse was locked in place. This had been an issue I have experienced occasionally; going into the Mouse Properties and choosing Reset Devices in Synaptics’ Device Settings tab always fixed this. This time, it did not. The touchpad could click or right-click, but it could not move or scroll.

Many, many hours of effort later, I am just about despairing. I have restarted, reinstalled the drivers, redownloaded drivers fresh, uninstalled the drivers entirely to let Windows try to fix the problem on its own, and installed new drivers in various versions, all to no avail. Some fix the movement problem, but all of them have their own problem(s). In each case, I have gone through Synaptics’ Settings with a fine-toothed comb to try to see if they would solve those problems, but they did not. I have tried disabling the laptop’s touchscreen, disabling the touchpad’s two-finger tap functionality, and none of it has fixed these problems.

I have also gone into Windows’ update history and uninstalled the latest updates. This did nothing to help. I also noticed that the latest updates were installed four days ago, rather than the less-than-two days since I last had a totally-working touchpad. So I am now less than sure that the restart I noticed at first was due to Windows Update, though I do not know what else would have caused it; the laptop has not otherwise exhibited unexpected restarts.

The specific drivers I have tried for this, with the problems each exhibited (per the list offered in Update Drivers → Browse my computer for driver software → Let me pick from a list of available drivers on my computer):

  • PS/2 Compatible Mouse—I believe these are the original drivers the laptop came with. Their performance is awful, with clicking barely working and two-finger scrolling not working at all.

  • Synaptics PS/2 Compatible TouchPad Version: 19.3.31.31 [8/16/2017]—Every click is a right-click, two-finger scrolling does not work.

  • Synaptics PS/2 Compatible TouchPad Version: 19.5.10.75 [9/21/2018]—The closest to success I’ve had; everything works except right-click never works, always resulting in a left-click. Two-finger tap does produce a right-click, but I find that gesture fairly awkward, and in any event it doesn’t really handle right-click-and-drag.

  • Synaptics SMBus ClickPad Version: 19.3.31.31 [8/16/2017]—Exhibits the locked-in-place behavior.

  • Synaptics SMBus ClickPad Version: 19.5.10.75 [9/21/2018]—Also exhibits the locked-in-place behavior. This is the driver that Windows installs when I allow it to automatically install the latest driver.

Also, for whatever reason, each of the Synaptics “PS/2 Compatible” driver versions are listed in duplicate. I have no idea what kind of connector physically exists within the laptop.

September 21, 2018 would have been about two months after I purchased the laptop, so I assume that the 19.3.31.31 version is what I had originally, that worked, but I do not specifically remember. It’s possible that I updated the drivers at some point, though again, I do not recall doing so. At any rate, none of them work now.

I am reasonably certain there are not hardware problems here. For one thing, the problems with each of the drivers are completely different, and for another, when I go into Synaptics’ Settings, I can for example set the right-click zone—and the demo pane correctly recognizes my clicks there, even when right-click doesn’t work (or when it always right-clicks).

Are there other relevant drivers I should try? Is there some other setting to look into? This is infuriating and since I use my touchpad primarily, it renders the entire laptop nearly useless to me. I do not want to use an external mouse at all. And I certainly don’t want to try to use the touchscreen for everything.

0

Finally solved this problem: I found this post on HP’s forum, which recommended deleting all Synaptics drivers, and installing Microsoft’s “Precision Touchpad Drivers” per these instructions.

In short, it’s the usual process of manually installing downloaded drivers: Device Manager, open the Synaptics (or Elan) touchpad device under Mice, choose to Upgrade Drivers, and then select “Let me choose” and “Have Disk” to install the downloaded drivers by browsing to the autorun.inf file in the downloaded archive (after extracting). The real key there are the links to the drivers themselves:

These drivers seem to work perfectly for me, despite Windows’ dire warning that they were the wrong drivers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.