0

0

I've written an asmx web service and am working on hosting it via IIS. I've added port bindings to my domain and I am able to access it externally by visiting my domain without issue.

The problem I'm having is that I can't use the default port 80 to host the web service, which I need to do because of limitations with mapping to specific ports.

Whenever I access the default port I'm redirected to my WD MyCloud website, basically the url is automatically appended with /UI (www.mydomain.com redirects to www.mydomain.com/UI)

As far as I can tell I don't have any DNS records that are pointing to that internal IP address and I don't have any http rewrites that would be sending traffic to that URL.

At this point I don't know if it's a router issue, a DNS issue, an IIS issue or possibly something else. I'm not even sure how to troubleshoot it to find out where this URL is coming from.

The only sure thing I can say is that when I log into my Linksys router and turn on the "Filter Internet NAT redirection" option, the redirects no longer happen and I am sent to the Linksys web URL, but none of my ports forward at that point.

  • So all is about externally accessing the ports, right? Also, do you have UPnP enabled in your modem/router? (You might want to disable that to stop devices and software from opening whatever they like.) And do you even need external access to your WD MyCloud? – Arjan Jan 13 '19 at 16:24
0

Whenever I access the default port I'm redirected to my WD MyCloud website.

It sounds like the WD MyCloud is acting as a "default" web server and is responding to any incoming http traffic.

As general advice, there are likely three basic solutions:

  1. Port forward HTTP/HTTPS traffic (80/443) on your router specifically to your IIS server (and relay any requests for the WD My Cloud to that device from there).

  2. If possible, change the ports that the WD My Cloud operates on for web access (i.e. change HTTP/HTTPS from 80/443 to something else).

  3. Run your own DNS server for www.mydomain.com (perhaps on the same machine as your IIS installation). You can use BIND on Windows, for example. You can then direct web traffic for www.mydomain.com to the correct machine on your network.

As a side note, I would avoid putting any device in the "DMZ" settings for your router since this device will likely have web traffic routed to it automatically.

0

I changed the DNS servers that my router uses to Google's DNS servers (8.8.8.8 and 8.8.8.4) and clearing my browser cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.